Recording unavailable AWS

hey
I have hosted jitsi and jibri on same AWS ec2 instance.
The jitsi meet works perfectly and everything looks good.
However the jibri wont start says “Recording unavailable”.

Jibri Logs:
org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=testingdomain.store hostname=testingdomain.store] error connecting
org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘testingdomain.store:5222’ failed because: testingdomain.store/3.142.211.49 exception: java.net.SocketTimeoutException: connect timed out

Please note i have already open port 5222/tcp in aws instance.
Any help will be appreciated.
@damencho

Thanks in advance.

What kind of instance and what kernel are you running?

Try this script, to test the environment,

hey
Thanks for replying.

I am using AWS ec2 with r4.large instance type.
I am using Ubuntu 20.04 with Linux 5.4.0-73-generic x86_64.
Also i am using Java 8 for Jibri.

I didnt understand the script that you have sent. Can you elaborate the same ?

R4 large is only 2 CPUs, that may be a problem. Try increasing CPUs to 4 and check.

If it still doesn’t work:

Is jibri running? If yes, share jibri logs.
Are you using jibri.conf? If yes, share that file?

Shared the jibri logs and jibri.conf file.
I have followed this to install and setup jibri.

It says connect timed out at 5222, i have opened outbound rules port at 5222



Is jibri running?
Check if prosody is listening on port 5222…

Last thing would be to increase the number of cores, as there were many instances where it worked.

Yes. Jibri status is running.

Also how to check if prosody is listening on 5222 ? Can you guide me ?

I went with r2.large since it worked for some. Check Link!

netstat -antp|grep 5222

Not sure about this response. Can you have a look ?

Looks good. Check if you are able to telnet to 5222.

telnet testingdomain.store 5222

Jibri logs will be in directory /var/log/jitsi/jibri

Stop jibri. Clear log.0.txt. start jibri

And share that log file log.0.txt(attach here)

For me it works with only 2 CPUs. Instance type is t2.medium.

But in general, jibri+jitsi on same server needs good server config.

hey
I found something,
In the logs, why this is checking for config.json when i have jibri.conf configured.
Can you help with this ?

It does check and use if that’s found. As your server has no such file, you may ignore it. It is not the source of the issue.

@Prachi_Tiwari You will have problems running the latest Jibri on 2vCPUs (and I suspect, just as low memory).

That aside, share your jibri.conf.

Add dns entry for testingdomain.store in /etc/hosts, pointing to 127.0.0.1 and check…

hey, What do you suggest den if i cannot run jibri with 2vCPU’s. I am working with AWS ec2 instance.
Also, the jibri.conf is attached below.
Please guide.



isnt that localhost ? In /etc/hosts i have given my AWS Ip which is

AWS ip >>domain name>>hostname
3.17.217.114 testingdomain.store ip-172-31-24-240

Sorry, just noticed you actually shared your jibri.conf earlier. Configuration looks ok to me on a quick glance.

To host Jitsi and Jibri on the same server, with the current Jibri default, I’d recommend perhaps 8 vCPU and 8GB of RAM. 4vCPU used to be ok, but for the higher resolution Jibri now defaults to, you need something higher.

Change that to localhost ip and check…

hey I changed it to localhost and its working now !
Maybe den i have to optimize my server.
But the problem is, I can see that the mp4 is recorded but
How to play video from terminal ?
or how to open this folder from terminal ?
xdg-open or Nautilus doesnt seem to work for me .
Is there any way ?