Recording Stopped (Recording failed to start)

Thanks @damencho :relaxed:,
After updating with mentioned changes Recording started working (Both Audio and Video)
For info of jicofo and jibri version:
JiCoFo 1.0.589 jibri -8.0-14-g88af8a1-1

thanks
Rakesh

@damencho

my jibri version is 8.0-14-g0ccc3f6-1. I am also getting [Recording Stopped (Recording failed to start).

log.0.txt output is here

2020-06-22 23:41:35.551 SEVERE: [45] org.jitsi.jibri.selenium.JibriSelenium.run() An error occurred while joining the call: org.openqa.selenium.WebDriverException: : Failed to read the ‘localStorage’ property from ‘Window’: Access is denied for this document.
(Session info: chrome=83.0.4103.106)
(Driver info: chromedriver=83.0.4103.39 (ccbf011cb2d2b19b506d844400483861342c20cd-refs/branch-heads/4103@{#416}),platform=Linux 4.15.0-106-generic x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘ksuvc’, ip: ‘10.161.9.158’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘4.15.0-106-generic’, java.version: ‘1.8.0_252’
Driver info: org.openqa.selenium.chrome.ChromeDriver

What if jitsi and jibri are on the same vm or server?

@damencho

Configures Jibri recording setup in separate instance . I have followed this tutorial for configuration.
https://nerdonthestreet.com/wiki?find=Set+Up+Jibri+for+Jitsi+Recording%3Aslash%3AStreaming

systemctl enable –now jibri
Failed to enable unit: Unit file \xe2\x80\x93now.service does not exist.

Sharing the log file details, please check.

log.0.txt (41.3 KB)

@masteryoda @jayswalniraj @saghul @

Recording automatically stoped after some times, please help me on this. Sharing my log file.
log.1.txt (25.0 KB)

  • Could you watch the resource utilisation (especially RAM) while recording

  • Be sure the default is java8

  • chromium from the official distro repo may be more stable than chrome. Its configuration is a bit different

Will check memory usage.

Using java 8 as default

chromium from the official distro repo may be more stable than chrome . Its configuration is a bit different: i didn’t understand this part.

jibri uses a chrome instance while recording or streaming. chrome is mostly installed from the chrome repo because most guide suggests this. But sometimes chrome may behave differently depending on the current version.

Ok, as per log file is there any issue in chrome instance.

Thank you.

Does you folder have the right permissions?
I mean can jibri write files there?

Hi @damencho, @saghul, I am facing the same issue when trying to record using multiple jibri inside docker container. Please refer below error in ffmpeg.0.txt
[x11grab @ 0x558c5acc5fc0] Stream #0: not enough frames to estimate rate; consider increasing probesize
2020-08-26 17:49:40.169 INFO: [657] ffmpeg.call() Input #0, x11grab, from ‘:0.0+0,0’:
2020-08-26 17:49:40.169 INFO: [657] ffmpeg.call() Duration: N/A, start: 1598444380.120526, bitrate: N/A
2020-08-26 17:49:40.169 INFO: [657] ffmpeg.call() Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 1280x720, 30 fps, 1000k tbr, 1000k tbn, 1000k tbc
2020-08-26 17:49:40.169 INFO: [657] ffmpeg.call() ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
2020-08-26 17:49:40.200 INFO: [657] ffmpeg.call() [alsa @ 0x558c5acd0260] cannot open audio device plug:bsnoop (No such device)
2020-08-26 17:49:40.201 INFO: [657] ffmpeg.call() plug:bsnoop: Input/output error

I have set up Alsa loopback device using the guide in https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-docker#jitsi-broadcasting-infrastructure-jibri-configuration
Also I have done loop back interface based the suggestion given by you. Please let me know how can I resolve. Also please be noted I can be able to record in a signle jibri. Only multiple Jibri at the same time is not working.

Hi @saghul
I did the setup of Jibri in an AWS Ubuntu 18.04 server. Did the work after adding your config file and it worked accurately. My issue is, in that instance, I entered an AMI. But it occurs an FFmpeg error in the AMI added Jibri. Have you got any ideas on this matter?

After executing this command (modprobe snd-aloop) I will get this output:-

Switch the standard Linux kernel. If it’s Ubuntu, IIRC it’s needed an extra kernel package too. Solved on the old posts

@emrah Could you please guide me to how to resolve that problem?

search for snd_aloop on Ubuntu

Do you mean execute this command on ubuntu terminal ? @emrah

Result is empty @emrah
image
Please have a look

I mean this is a frequently replied issue. You can find the solution on the old topics

Hi @emrah
Thank you very much. I 'll have a look.

Hi @emrah
I loaded a snd_aloop module for the first time, according to what was told by Sagul. Now I can’t load that. The reason is, I’ve entered an AWS AMI. The Jibri also stopped working after creating the AMI. Thank you