Recording start error

Hello. Actually set up the server on this topic, but the recording does not work, I did not find anything similar on the forum and nothing useful to me in the logs, so I ask for help.

jibri log (log.2.txt)

if you click on the record button in the browser console it appears:
image

Also i could’t install alsaa and loopback because:

root@ubuntu-jitsi-v2-records:/var/log# modprobe snd-aloop
modprobe: FATAL: Module snd-aloop not found in directory /lib/modules/4.15.0-96-generic

Thanks.

Hi @Xenx, regarding the alsa issues you mention: I’m not sure which ubuntu you have for your jibri, you may need to install linux-image-extra-virtual which contains the alsa modules…

I would not be able to followup on you other issue, you somebody else will be able to help…

Cheers, Igor

I installed linux-image-extra-virtual, but all the same modules were not searched.

Please refer to Jibri official docs: “jibri was tested only on Ubuntu 16.04”, maybe works also on 18.04.
Plase follow the guide step by step

Also you can check this Jibri error:

2020-04-24 13:31:00.670 SEVERE: [19] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionAuthenticatedListener() Exception in authenticated listener
java.lang.RuntimeException: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.auth.class.vot.by: XMPPError: remote-server-not-found - cancel

after install linux-image-extra-virtual, reboot ubuntu server and that’s ok

root@jitsimeet:~# lsmod | grep snd_aloop
snd_aloop              24576  0
snd_pcm                98304  1 snd_aloop
snd                    81920  3 snd_timer,snd_aloop,snd_pcm