Recording not available after several attempts installing jitsi-meet and jibri under Ubuntu 16.04


#1

s a “non programmer” I made several attempts to install jibri exactly the way as shown in the instruction youtube videos. However jitsi-meet works but recording ist still not available. It seems that a Jibri cannot be found:
Jicofo 2019-01-22 14:56:43.547 SCHWERWIEGEND: [102] org.jitsi.jicofo.recording.jibri.JibriSession.log()
Jicofo 2019-01-22 14:56:43.548 INFORMATION: [102] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Failed to start a Jibri session, no Jibris available

The jvb.log for the relevant period reports a healthy videobridge.
Finally the jbri log for the relevant period shows:
2019-01-22 14:44:57.588 INFORMATION: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will$
2019-01-22 14:45:27.615 WARNUNG: [22] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2019-01-22 14:45:30.809 SCHWERWIEGEND: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: 2019-01-22 14:45:30.867 WARNUNG: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime d

To my best knowledge I filled in the files with the relevant DNS entries and finally exhausted would be happy for a problemsolving advice and would also be willing to pay for.


#2

what versions of Jicofo/Jibri are you using? Do you have the JibriBrewery muc config set up on Jicofo and Jibri? Please include Jibri and Jicofo logs.


#3

Here the requested infos. Log files enclosed. Please see the extracted “severe” and “warnings” out of the relevant log files. Please also note that there is an inconsistency between the jibri installation video and the instructions: The settings on the website shows following file name:
/etc/jitsi/meet/yourdomain.config.js
The jitsi meet installation produced: /etc/jitsi/meet/meeting.optikerkoller.at-config.js.
However, neither versions did remedy the situation.
The actual Versions are:
dpkg -l jicofo: 1.0-451-1
dpkg -l jibri 7.2.71-1
jicofo settings in sip-communicator.properties:

org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.meeting.optikerkoller.at
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=120
org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1

jibri settings:
“control_muc”: {
“domain”: “internal.auth.meeting.optikerkoller.at”,
“room_name”: “JibriBrewery”,
“nickname”: “jibri-nickname”
Thank you in advance for your hopefully problem solving advices.
jibri.log (2.9 KB)
JVBErrorWarning.log (1.0 KB)
JVB.log (53.1 KB)
jicofoERROR_WARNING.log (5.7 KB)
jicofo.log (27.5 KB)

After finding a comment on ownership of configuration jicofo configuration files I found out that some of the configuration files only had read permisson for root. However after setting the read bit for jicofo things improoved- a little.
Trouble starts with the following message in jicofo.log:

WARNUNG: [43] org.jitsi.jicofo.BridgeSelector.addJvbAddress().227 No pub-sub node mapped for jitsi-videobridge.meeting.optikerkoller.at

After some search I found a recommendation which I do not really understand:
Make sure in the list of admins in prosody you have jicofo and all your jvb
_ component addresses_.”
A relevant place for such an entry would be in prosody.conf.lua in
admins = { }
Which remains empty after “quick” installation. If there entries are necessary, is it then possible to clarify exactly which users have to be placed between the brackets? I.E. {john.doe@doe.com, jeff.doe@doe.com} and/or {jicofo, jibri, and, which, server, name, else}

Hep to get the application running after 6 weeks playing around with would be very much appreciated.


#4

It looks like Jibri can’t connect to the xmpp server:

2019-01-26 17:20:50.382 SCHWERWIEGEND: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: '88.117.245.227:5222' failed because: /88.117.245.227 exception: java.net.SocketTimeoutException: connect timed out

Are you sure you can reach the xmpp server address from the Jibri machine?


#5

I corrected a typing error in the recorder passwords on both machines. However, there still is no success.

Probably relevant seems this info in Jicofo log:
Jicofo 2019-02-01 19:07:35.375 SCHWERWIEGEND: [40] org.jitsi.jicofo.recording.jibri.JibriSession.log() Unable to find an available Jibri, can’t start

It seems to correlate with the info in the Jibri log:
2019-02-01 19:05:35.652 SCHWERWIEGEND: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘88.117.245.227:5222’ failed because: /88.117.245.227 exception: java.net.ConnectException: Verbindungsaufbau abgelehnt (Connection refused)

However, each machine can ping the other one in due time, find the ping stats amended in the log files.

Please find enclosed relevant config files, jibri log, jvb log and jicofo log.
JicofoSip-communicator.properties.txt (208 Bytes)
JibriConfig.txt (3.5 KB)
jibri.log (3.5 KB)
Jicofo.log (20.6 KB)
jvb.log (93.3 KB)


#6

I have the same problem.
Where do you find the log files? I have a Debian system for Jitsi and Ubuntu for Jibri.
In which directory/folder should i search?
ty


#7

Prosody log files are in /vsr/log/prosody/ and all the Jitsi logs are in subfolders of /var/log/jitsi/


#8

ty.
I have jicofo.log, jicofo.log.1.gz, jicofo.log.2.gz, … jicofo.log.7.gz /
vb.log, jvb.log.1, jvb.log.2.gz.
Is this normal?

And I cant find the log files for Jibri/ there aren’t any logs. There is jsut a empty folder called jibri…


#9

Yes it’s normal. If you don’t have jibri logs, maybe it’s not running?


#10

I tried “sudo systemctl restart jibri”.
Folder is still empty…


#11

Did you try status?
systemctl status jibri

or
journalctl -u jibri

See the syslog too, see if there are running processes for jibri.


#12

root@jibri:/var/log/jitsi# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: active (running) since Tue 2019-02-05 12:08:17 UTC; 1h 46min ago
Process: 25801 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=0/
Main PID: 25844 (java)
Tasks: 32 (limit: 4915)
CGroup: /system.slice/jibri.service
└─25844 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.proper

Feb 05 12:08:23 jibri launch.sh[25844]: at org.eclipse.jetty.util.component.Con
Feb 05 12:08:23 jibri launch.sh[25844]: at org.eclipse.jetty.server.handler.Abs
Feb 05 12:08:23 jibri launch.sh[25844]: at org.eclipse.jetty.server.Server.doSt
Feb 05 12:08:23 jibri launch.sh[25844]: at org.eclipse.jetty.util.component.Abs
Feb 05 12:08:23 jibri launch.sh[25844]: at org.jitsi.jibri.MainKt.launchHttpSer
Feb 05 12:08:23 jibri launch.sh[25844]: at org.jitsi.jibri.MainKt.main(Main.kt:
Feb 05 12:08:23 jibri launch.sh[25844]: 2019-02-05 12:08:23.108:INFO:oejsh.ContextHandl
Feb 05 12:08:23 jibri launch.sh[25844]: 2019-02-05 12:08:23.126:INFO:oejs.AbstractConne
Feb 05 12:08:23 jibri launch.sh[25844]: 2019-02-05 12:08:23.132:INFO:oejs.Server:main:
Feb 05 12:08:51 jibri launch.sh[25844]: 2019-02-05 12:08:51.857 WARNUNG: [22] org.jives

root@jibri:/var/log/jitsi# journalctl -u jibri
– Logs begin at Tue 2019-01-29 09:11:33 UTC, end at Tue 2019-02-05 13:49:15 UTC. –
Jan 29 14:28:58 jibri systemd[1]: Started Jibri Process.
Jan 29 14:28:58 jibri systemd[1]: Stopping Jibri Process…
Jan 29 14:28:58 jibri graceful_shutdown.sh[13408]: % Total % Received % Xferd Ave
Jan 29 14:28:58 jibri graceful_shutdown.sh[13408]: Dlo
Jan 29 14:28:58 jibri graceful_shutdown.sh[13408]: [158B blob data]
Jan 29 14:28:58 jibri systemd[1]: jibri.service: Control process exited, code=exited st
Jan 29 14:28:58 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jan 29 14:28:58 jibri systemd[1]: Stopped Jibri Process.
Jan 29 14:28:58 jibri systemd[1]: Started Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Stopping Jibri Process…
Jan 29 14:28:59 jibri graceful_shutdown.sh[13422]: % Total % Received % Xferd Ave
Jan 29 14:28:59 jibri graceful_shutdown.sh[13422]: Dlo
Jan 29 14:28:59 jibri graceful_shutdown.sh[13422]: [158B blob data]
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Control process exited, code=exited st
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jan 29 14:28:59 jibri systemd[1]: Stopped Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Started Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Stopping Jibri Process…
Jan 29 14:28:59 jibri graceful_shutdown.sh[13437]: % Total % Received % Xferd Ave
Jan 29 14:28:59 jibri graceful_shutdown.sh[13437]: Dlo
Jan 29 14:28:59 jibri graceful_shutdown.sh[13437]: [158B blob data]
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Control process exited, code=exited st
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Main process exited, code=exited, stat
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jan 29 14:28:59 jibri systemd[1]: Stopped Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Started Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Stopping Jibri Process…
Jan 29 14:28:59 jibri graceful_shutdown.sh[13469]: % Total % Received % Xferd Ave
Jan 29 14:28:59 jibri graceful_shutdown.sh[13469]: Dlo
Jan 29 14:28:59 jibri graceful_shutdown.sh[13469]: [158B blob data]
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Control process exited, code=exited st
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Main process exited, code=exited, stat
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jan 29 14:28:59 jibri systemd[1]: Stopped Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Started Jibri Process.
Jan 29 14:28:59 jibri systemd[1]: Stopping Jibri Process…
Jan 29 14:28:59 jibri graceful_shutdown.sh[13498]: % Total % Received % Xferd Ave
Jan 29 14:28:59 jibri graceful_shutdown.sh[13498]: Dlo
Jan 29 14:28:59 jibri graceful_shutdown.sh[13498]: [158B blob data]
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Control process exited, code=exited st
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Main process exited, code=exited, stat
Jan 29 14:28:59 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
lines 1-43


#13

Finally!!
After playing around for another day the problem now is solved:

ufw allow 5222/tcp on jibri machine added!

Firewall settings for the working jibri server now:
[ 1] 22 ALLOW IN Anywhere
[ 2] 5222/tcp ALLOW IN Anywhere

Although I learned a lot when using editors and learned to understand shell syntax, a lot of wasted time passed by with the issue a remarkable number of people seem to be confrontated with. Perhaps it would be a good idea to mention the firewall settings for the jibri server in the relevant instructions.

Once more thanks for the hints and remarks I received.