Recording failed to start

Hi,
I installed and configured jitsi and jibri to record my meetings.
when I click on record button, an error message appears and says failed to start recording.
Here is Jibri logs:

2021-02-14 14:47:12.256 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2021-02-14 14:47:12.413 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Checking legacy config file /etc/jitsi/jibri/config.json
2021-02-14 14:47:12.414 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Legacy config file /etc/jitsi/jibri/config.json doesn’t exist
2021-02-14 14:47:13.558 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() got jwtConfig: {}

2021-02-14 14:47:13.559 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: reference.conf @ jar:file:/opt/jitsi/jibri/jibri.jar!/reference.conf: 52: No configuration setting found for key ‘signing-key-path’
2021-02-14 14:47:13.771 INFO: [1] org.jitsi.jibri.Main.main() Using port 8001 for internal HTTP API
2021-02-14 14:47:13.788 FINE: [19] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-02-14 14:47:14.262 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2021-02-14 14:47:14.273 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on s1ahn1.denaos.ir with config XmppEnvironmentConfig(name=eb-environment, xmppServerHosts=[s1ahn1.denaos.ir], xmppDomain=s1ahn1.denaos.ir, controlLogin=XmppCredentials(domain=auth.s1ahn1.denaos.ir, username=jibri, password=JibrisPass), controlMuc=XmppMuc(domain=internal.auth.s1ahn1.denaos.ir, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.s1ahn1.denaos.ir, username=recorder, password=RecordersPass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2021-02-14 14:47:14.275 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2021-02-14 14:47:14.312 INFO: [1] org.jitsi.jibri.Main.main() Using port 8002 for HTTP API
2021-02-14 14:47:14.320 WARNING: [28] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2021-02-14 14:47:14.601 INFO: [28] org.jitsi.xmpp.mucclient.MucClient.log() Connected.
2021-02-14 14:47:14.602 INFO: [28] org.jitsi.xmpp.mucclient.MucClient.log() Logging in.
2021-02-14 14:47:14.727 INFO: [28] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal.auth.s1ahn1.denaos.ir
2021-02-14 14:48:13.768 FINE: [19] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status

When I execute service jibri status I get the following output:
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset>
Active: active (running) since Sun 2021-02-14 14:48:44 CET; 3min 49s ago
Main PID: 849 (java)
Tasks: 49 (limit: 9445)
Memory: 164.5M
CGroup: /system.slice/jibri.service
└─849 java -Djava.util.logging.config.file=/etc/jitsi/jibri/loggi>

Feb 14 14:48:44 s1ahn1.denaos.ir systemd[1]: Started Jibri Process.
Feb 14 14:48:48 s1ahn1.denaos.ir launch.sh[849]: SLF4J: Failed to load class ">
Feb 14 14:48:48 s1ahn1.denaos.ir launch.sh[849]: SLF4J: Defaulting to no-opera>
Feb 14 14:48:48 s1ahn1.denaos.ir launch.sh[849]: SLF4J: See http://www.slf4j.o>

What is the problem and how can i solve it?

There are multiple posts with similar issue. Did you check them? Like jibri.conf - #50 by dr.h

Or there’s one tutorial by @Freddie on how to install/troubleshoot jibri. Did you check that one too?

Both those posts combined together should solve your issue(unless it is completely different)

You can find those posts on this…How to install jibri(Recording and live streaming) and etherpad in Jitsi Meet

Thanks :slight_smile:
I will try them as soon as possible, but with a quick glance I did the same setup.

If you want a quick fix, you may reinstall using this script and check GitHub - pregalla/jitsi: Installer for Jitsi, Jigasi, and Jibri
Will take around 10 min to get everything up and running.

1 Like

Thanks very much! :slight_smile:
Does your script support JWT authentication too?

Not yet. Yet to explore that myself.

And can I ommit the Jigasi part?

Yes. You may choose to install only jitsi-meet and jibri.

Post the results once done.

Thanks Very much for your help :heart:

I used your script, but still getting the same error.
this time I got the error 3 times when I clicked record button once!

Ok. What platform is your server running on?

Please post jibri.conf, jibri logs so that other experienced users can check.

Post installer log, so I can check if there are any errors with installer.

I reinstalled chromedriver manually, and everything worked like a charm :slight_smile:
Thank you very much for your help! :heart:

Great. Chromedriver should have been installed as part of installation. Anyhow you got it working.

Appreciate if you can send me here or via direct message the log strings containing word chrome…

Where is the log file saved?

your_home_dir/jitsi

Installing stable version of Google Chrome…

Uninstalling Chrome if already installed…

Google Chrome Stable build Install COMPLETE…

Google Chrome version installed: Google Chrome 88.0.4324.150

Installing compatible Google ChromeDriver now…

Chromedriver install COMPLETE…

ChromeDriver version installed:

Running compatibility check…

Google Chrome 88.0.4324.150

Chrome and ChromeDriver are compatible…

Thanks. Some issue installing Chromedriver.

Ideally it should say:

Installing compatible Google ChromeDriver now…

Chromedriver install COMPLETE…

ChromeDriver version installed: 88.0.4324.96

Running compatibility check…

Google Chrome 88.0.4324.150
ChromeDriver 88.0.4324.96 (68dba2d8a0b149a1d3afac56fa74648032bcf46b-refs/branch-heads/4324@{#1784})

Chrome and ChromeDriver are compatible…

Hi,
I used the server I installed with your script today in production.
the first meetings was very good and it recorded and saved successfuly for about an hour and five minutes.
but the second meeting, every two minute it just sent a recording failed error and stopped recording.
when I checked the logs, I found out that the problem is an ALSA buffer xrun.
I monitored ram usage and i found out that the ram is being occupied up madly after starting recording, about 2 GB in 2 minutes!
my server specs are 8GB RAM, 4vCore cpu.
I tried downgrading chrome and chromedriver as mentioned here, but no luck.
Any idea what should I do?

Not sure what the problem is. But better if you can start a new thread for this, as the issue is different.