Recording failed to start

image

The structure is like this

image

/tmp/chromedriver.log

[1593484453.727][INFO]: Starting ChromeDriver 83.0.4103.39 (ccbf011cb2d2b19b506d844400483861342c20cd-refs/branch-heads/4103@{#416}) on port 65420
[1593484453.728][INFO]: Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping ChromeDriver safe.
[1593484454.153][INFO]: [66f95709ca6b00c69995cdb91de4734c] COMMAND InitSession {
   "capabilities": {
      "desiredCapabilities": {
         "browserName": "chrome",
         "goog:chromeOptions": {
            "args": [ "--use-fake-ui-for-media-stream", "--start-maximized", "--kiosk", "--enabled", "--disable-infobars", "--alsa-output-device=plug:amix", "--autoplay-policy=no-user-gesture-required" ],
            "extensions": [  ],
            "w3c": false
         },
         "loggingPrefs": {
            "driver": "ALL"
         }
      },
      "firstMatch": [ {
         "browserName": "chrome",
         "goog:chromeOptions": {
            "args": [ "--use-fake-ui-for-media-stream", "--start-maximized", "--kiosk", "--enabled", "--disable-infobars", "--alsa-output-device=plug:amix", "--autoplay-policy=no-user-gesture-required" ],
            "extensions": [  ],
            "w3c": false
         }
      } ]
   },
   "desiredCapabilities": {
      "browserName": "chrome",
      "goog:chromeOptions": {
         "args": [ "--use-fake-ui-for-media-stream", "--start-maximized", "--kiosk", "--enabled", "--disable-infobars", "--alsa-output-device=plug:amix", "--autoplay-policy=no-user-gesture-required" ],
         "extensions": [  ],
         "w3c": false
      },
      "loggingPrefs": {
         "driver": "ALL"
      }
   }
}
[1593484454.155][INFO]: Populating Preferences file: {
   "alternate_error_pages": {
      "enabled": false
   },
   "autofill": {
      "enabled": false
   },
   "browser": {
      "check_default_browser": false
   },
   "distribution": {
      "import_bookmarks": false,
      "import_history": false,
      "import_search_engine": false,
      "make_chrome_default_for_user": false,
      "skip_first_run_ui": true
   },
   "dns_prefetching": {
      "enabled": false
   },
   "profile": {
      "content_settings": {
         "pattern_pairs": {
            "https://*,*": {
               "media-stream": {
                  "audio": "Default",
                  "video": "Default"
               }
            }
         }
      },
      "default_content_setting_values": {
         "geolocation": 1
      },
      "default_content_settings": {
         "geolocation": 1,
         "mouselock": 1,
         "notifications": 1,
         "popups": 1,
         "ppapi-broker": 1
      },
      "password_manager_enabled": false
   },
   "safebrowsing": {
      "enabled": false
   },
   "search": {
      "suggest_enabled": false
   },
   "translate": {
      "enabled": false
   }
}
[1593484454.155][INFO]: Populating Local State file: {
   "background_mode": {
      "enabled": false
   },
   "ssl": {
      "rev_checking": {
         "enabled": false
      }
   }
}
[1593484454.157][INFO]: Launching chrome: /usr/bin/google-chrome --alsa-output-device=plug:amix --autoplay-policy=no-user-gesture-required --disable-background-networking --disable-client-side-phishing-detection --disable-default-apps --disable-hang-monitor --disable-infobars --disable-popup-blocking --disable-prompt-on-repost --disable-sync --enable-automation --enable-blink-features=ShadowDOMV0 --enable-logging --enabled --kiosk --load-extension=/tmp/.com.google.Chrome.2p79Sk/internal --log-level=0 --no-first-run --password-store=basic --remote-debugging-port=0 --start-maximized --test-type=webdriver --use-fake-ui-for-media-stream --use-mock-keychain --user-data-dir=/tmp/.com.google.Chrome.cg8yek data:,
[1593484455.583][INFO]: [66f95709ca6b00c69995cdb91de4734c] RESPONSE InitSession ERROR session not created
from disconnected: unable to connect to renderer
  (Session info: chrome=83.0.4103.116)

Recording fails when you start recording with all installations followed.
Please help me

Customize these lines according to your environment.

The problem is the /etc/hosts problem.
105.77.225.133 testrtc.jitabc.com -> 105.77.225.132 testrtc.jitabc.com

This post was flagged by the community and is temporarily hidden.