Recording failed to start

I wanted to add a recording feature to my Jitsi server Ubuntu 18.04,
so I installed Jibri along the URL: https://github.com/jitsi/jibri.
We are now adding Jibri to the Jitsi server instead of a standalone Jibri server.
I also tried the standalone Jibri, but it didn’t link work.

The recording gives the message “Recording failed to start”.
I searched a lot, however the results did not change no matter what I tried.
Please give me any advices.

By the way, the “error” part of the logs are in the linked error.txt.
the “false” parts in false.txt.
https://384141.jp/Samples/error.txt
https://384141.jp/Samples/false.txt
The domain names in the log have been changed.

I don’t think it’s relevant, but
a. I’ve set up “Secure Domain setup” to my Jitsi web.
URL: https://jitsi.github.io/handbook/docs/devops-guide/secure-domain.
b. The Jitsi server requires an SSH Key.

Thank you.

Can you paste /var/log/jitsi/jibri/ffmpeg.0.txt

Thank you for the reply.
And please allow the reply to be delayed due to the time difference.

There is no file ffmpeg.0.txt.

root@my:~#
root@my:~# ls -la /var/log/jitsi/jibri/
total 1836
drwxrwxr-x 2 root jitsi 4096 Jun 13 15:56 .
drwxrwx— 3 jvb jitsi 4096 Jun 14 06:25 …
-rw-r–r-- 1 jibri jibri 187318 Jun 13 15:56 log.0.txt
-rw-r–r-- 1 jibri jibri 185584 Jun 13 15:52 log.1.txt
-rw-r–r-- 1 jibri jibri 185572 Jun 13 15:50 log.2.txt
-rw-r–r-- 1 jibri jibri 187311 Jun 13 15:33 log.3.txt
-rw-r–r-- 1 jibri jibri 187318 Jun 13 14:17 log.4.txt
-rw-r–r-- 1 jibri jibri 187307 Jun 13 13:57 log.5.txt
-rw-r–r-- 1 jibri jibri 183618 Jun 13 11:29 log.6.txt
-rw-r–r-- 1 jibri jibri 183611 Jun 13 11:26 log.7.txt
-rw-r–r-- 1 jibri jibri 187547 Jun 13 11:26 log.8.txt
-rw-r–r-- 1 jibri jibri 183618 Jun 13 10:56 log.9.txt
root@my:~#
root@my:~#
root@my:~# find / -name ffmpeg.0.txt -print
root@my:~#
root@my:~#
root@my:~# find / -name ffmpeg* -print
/var/lib/dpkg/info/ffmpeg.conffiles
/var/lib/dpkg/info/ffmpeg.md5sums
/var/lib/dpkg/info/ffmpeg.list
/var/cache/apt/archives/ffmpeg_7%3a3.4.6-0ubuntu0.18.04.1_amd64.deb
/usr/share/doc/ffmpeg
/usr/share/man/man1/ffmpeg-devices.1.gz
/usr/share/man/man1/ffmpeg-bitstream-filters.1.gz
/usr/share/man/man1/ffmpeg-scaler.1.gz
/usr/share/man/man1/ffmpeg-protocols.1.gz
/usr/share/man/man1/ffmpeg.1.gz
/usr/share/man/man1/ffmpeg-formats.1.gz
/usr/share/man/man1/ffmpeg-resampler.1.gz
/usr/share/man/man1/ffmpeg-codecs.1.gz
/usr/share/man/man1/ffmpeg-all.1.gz
/usr/share/man/man1/ffmpeg-utils.1.gz
/usr/share/man/man1/ffmpeg-filters.1.gz
/usr/share/ffmpeg
/usr/share/lintian/overrides/ffmpeg
/usr/bin/ffmpeg
root@my:~#
root@my:~#
root@my:~#
root@my:~# sudo apt-get install ffmpeg -y
Reading package lists… Done
Building dependency tree
Reading state information… Done
ffmpeg is already the newest version (7:3.4.6-0ubuntu0.18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
root@my:~#
root@my:~# cat /var/lib/dpkg/info/ffmpeg.conffiles
/etc/ffserver.conf
root@my:~#
root@my:~#
root@my:~# cat /etc/ffserver.conf
… etc.
CustomLog -
… etc.

it’s quite clear that this is where it goes bad:
2020-06-13 14:57:09.892 SEVERE: [41] org.jitsi.jibri.api.xmpp.XmppApi.run() Error starting Jibri service : org.jitsi.jibri.util.CallUrlInfoFromJidException: Unable to extract call url info from Jid hypers@conference.meet.my-domain,com (stripFromRoomDomain = conference., xmppDomain = xmpp.domain) with stack:

now as you have masked your true domain it’s somewhat difficult for an external observer to guess why Jibri fails to extract an URL from your Xmpp info.
I think there is not really a comma in your xmpp domain ? (my-domain,com)
Anyway, there is a possibility that the exception stack that you did not include in the log may somehow contain the reason why the exception occurred. Reading Java stack traces is a black art that usually brings no useful information but sometimes it can be enlightening.

This means that Jibri failed before trying to start ffmpeg.

Is there really a comma there?

,com

From the conclusion, it’s starting to recording, thank you.

The problem was in the /etc/jitsi/jicofo/sip-communicator.properties file.
For me Japanese, I could not understand the chapter “Jicofo” of https://github.com/jitsi/jibri.
Originally, it should be modified and added. Now I think .
However I was rewriting everything or adding it as it was.
It also was difficult for me to reading “Edit the config.json file
(installed to /etc/jitsi/jibri/config.json by default) appropriately.” at “Config files” chapter.

Anyway, thank you.

It’s a bit strange, but the recorded .mp4 file is unreadable or invisible in various software.
Does someone have a same problem?

If noone, we will create a new question.

while I can’t read Japanese, I wanted a bit of light fun and tried to enter the following sentence

This should be the same MUC as is referenced in jibri's `config.json` file

in a few translation engines to get it into japanese and in another translation engine to get it back into english. It was a complete mess. I understand why you had difficulties, there must be in this simple (?) sentence something that must be a bit alien in the japanese language. I tried to formulate the same idea differently to make the sentence more explicit with little success.

Unless it’s empty, something I could understand if you are trying to run Jibri on a computer with too little memory, you could try this little trick that I have found in a post on this forum: create a file named /usr/local/bin/ffmpeg and make it executable, then configure it as following

#!/bin/bash
echo $@ >> /tmp/ffmpeg.log
ARGS=$@
exec /usr/bin/ffmpeg $ARGS

in this way you should get the arguments passed to ffmpeg in /tmp/ffmpeg.log, something that may help in understanding why the result is not readable. BTW, you should use ffplay to check if the file is good.

Thank everyone in the forum.
Someday I would like to contribute too to jitsi.

About “Jicofo” description:

The file has only 4 lines, so I think the sample code is appropriate.
I’m not good at English.
However, If the text is good, why not something like the following?

Add the following two lines at the end of file /etc/jitsi/jicofo/sip-communicator.properties (or similar),
and Edit the file appropriately as a whole. …etc.

I copied the chapter “Config files”.
I’ve done reverse translations a number of times, but it didn’t break the meaning.

About broken mp4 files

There is enough memory.

I changed ffmpeg.log to ffmpeg.0.txt and ran it.
exec /usr/bin/ffmpeg $ARGS
However, the result was ending with the following message and I got nothing.
" Use -h to get full help or, even better, run ‘man ffmpeg’ "

I have tried the following:
ffmpeg -i xxx_2020-06-14-19-15-52.mp4
The result was:
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x555f47894820] moov atom not found
xxx_2020-06-14-19-15-52.mp4: Invalid data found when processing input

There seems to be something other problem.
I make another issue. It seems that it’s been too different from this theme.

I close this issue.

I write this for later people.

The problem with “broken mp4 files” has also been resolved.

It was solved by the following discussion URL.
In short I had to lower the java version from 11.11.0.7 to 8.I.

Thanks Forum.