Recording failed to start

I an new on Jitsi Meet and getting the message “Recording failed to start” when clicking on “Start Recording” button. Not getting any specific error or any error on console.
Where can i get the log for error? Please help me

you should look into jibri logs, located at path /var/log/jitsi/jibri

log.0.txt (20.6 KB)

Thanks
Bhavin_Jagad, I have got the error. Attach together the log file.
I think this is the error
Error starting Jibri service : org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited abnormally

I am Running on Virtual Machine
Description: Ubuntu 18.04.4 LTS
Codename: bionic

Please help me to solve it.

This is my new log from jibribrowser.0.txt (35.9 KB) log.0.txt (17.3 KB)

2020-05-19 14:23:19.908 INFO: [55] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2020-05-19 14:23:19.910 INFO: [55] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call
2020-05-19 14:23:19.911 INFO: [55] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Current service had an error, sending error iq
2020-05-19 14:23:19.912 FINE: [55] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: stop:recording

Please guide me to get recording working

From your log, it seems that it can’t open chrome browser. I haven’t setup jitsi on virtual machine but you can find SEVER part in your log and google it for solution.

Hi .
I install jitsi and jibri and wish for streaming on my own rtmp server. but in advance i have a problem, please guide me if you can.
i get an error message when i want to record something, it says :Recording failed to start and recording unavailable.
An other issue is that during the jibri installation, when i have to make changes the file in /etc/jitsi/jibri/config.json , this file does not exist at all, and i have to create it my self.
This file does not even exist in the Github documents, but it is a part of installation instruction.
May the recording problem be related to this issue?
Any tips on solving my recording problem will make me happy and thankful.

I’m facing the same issue. Developers changed the old config.json file with the jibri.conf file. You can check the link here.

1 Like

thank you so much

hi, i want you ask if you solve the recording problem in jibri. i change .json file to jibri.config.
my jibri. conf is like this:
jibri {
api {
http {
external-api-port = 2222,
internal-api-port = 3333
},
xmpp {
environments = [
{
name = “prod environment”,
xmpp-server-hosts = [“stream.ictsg.ir”],
xmpp-domain = “stream.ictsg.ir”,

                control-muc {
                    domain = "internal.auth.stream.ictsg.ir",
                    room-name = "JibriBrewery",
                    nickname = "jibri-nickname"
                },

                control-login {
                    domain = "auth.stream.ictsg.ir",
                    username = "jibri",
                    password = "JibrisPass"
                },

                sip-control-muc {
                    domain = "stream.ictsg.ir",
                    room-name = "JibriBrewery",
                    nickname = "jibri-nickname"
                },

                call-login {
                    domain = "recorder.ictsg.ir",
                    username = "recorder",
                    password = "RecordersPass"
                },

                strip-from-room-domain = "stream.ictsg.ir",
                usage-timeout = "0",
                call-login {
                    domain = "recorder.ictsg.ir",
                    username = "recorder",
                    password = "RecordersPass"
                },

                strip-from-room-domain = "stream.ictsg.ir",
                usage-timeout = "0",
                trust-all-xmpp-certs = true
            }
        ]
    },
single-use-mode = true,
stats {
    enable-stats-d = true
},
recording {
    recordings-directory = "/srv/recordings",
    finalize-script = "/path/to/finalize_recording.sh"
}

}

//////////////////////////////////////////////////////////////////////
is this correct?

but i have this error when i want to restart jibri:


//////////////////////////////////////////////////////////////////////////////////////////////////////////
jicofo and videobridge start without problem. when I control natstatus i don’t have 3333 port at all…
any tips for me please!
thank you in advance

I can’t record too but i find this jibri.conf configuration. After that jibri.service started to working again you can check it here.

thank you so much dear fth.
are yuo able to streaming with it? or it does n’t work like recording!!!