Recording failed to start


#1

When I try to start a recording with jibri I get the message “Recording failed to start”.
My Jibri logs are empty, but is running :

root@jibri:/var/log/jitsi/jibri# service jibri status
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: active (running) since Mon 2019-02-11 11:57:11 UTC; 12min ago
Process: 5013 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=0/SUCCESS)
Main PID: 5065 (java)
Tasks: 35 (limit: 4915)
CGroup: /system.slice/jibri.service
└─5065 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/ji

Feb 11 12:02:41 jibri launch.sh[5065]: org.jitsi.jibri.service.impl.FileRecordingJibriService.(FileReco
Feb 11 12:02:41 jibri launch.sh[5065]: org.jitsi.jibri.JibriManager.startFileRecording(JibriManager.kt:134)
Feb 11 12:02:41 jibri launch.sh[5065]: org.jitsi.jibri.api.xmpp.XmppApi.handleStartService(XmppApi.kt:290)
Feb 11 12:02:41 jibri launch.sh[5065]: org.jitsi.jibri.api.xmpp.XmppApi.access$handleStartService(XmppApi.kt:
Feb 11 12:02:41 jibri launch.sh[5065]: org.jitsi.jibri.api.xmpp.XmppApi$handleStartJibriIq$1.run(XmppApi.kt:2
Feb 11 12:02:41 jibri launch.sh[5065]: java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executor
Feb 11 12:02:41 jibri launch.sh[5065]: java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
Feb 11 12:02:41 jibri launch.sh[5065]: java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
Feb 11 12:02:41 jibri launch.sh[5065]: java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
Feb 11 12:02:41 jibri launch.sh[5065]: java.base/java.lang.Thread.run(Thread.java:844)

Java-version:
root@jibri:/var/log/jitsi/jibri# java -version
java version “1.8.0_201”
Java™ SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot™ 64-Bit Server VM (build 25.201-b09, mixed mode)
root@jibri:/var/log/jitsi/jibri#
on jibri

root@Jitsi:/home/jitsi# java -version
openjdk version “1.8.0_181”
OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-2~deb9u1-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)
on jitsi

jicofo_1.0-440-1_amd64.deb
jicofo_1.0-451-1_amd64.deb
jitsi-meet_1.0.3383-1_all.deb
jitsi-meet_1.0.3508-1_all.deb
jitsi-meet-prosody_1.0.3081-1_all.deb
jitsi-meet-prosody_1.0.3186-1_all.deb
jitsi-meet-web_1.0.3081-1_all.deb
jitsi-meet-web_1.0.3186-1_all.deb
jitsi-meet-web-config_1.0.3081-1_all.deb
jitsi-meet-web-config_1.0.3186-1_all.deb
jitsi-videobridge_1093-1_amd64.deb
jitsi-videobridge_1104-1_amd64.deb

jibri_7.2.71-1_all.deb
google-chrome-stable_72.0.3626.96-1_amd64.deb

ty


#2

Please, creating new topics for the same problem will not help you, you can just annoy people in the community.
As I wrote in you in the other post, please provide the full logs so we can see the whole stack trace of the error.


#3

sry… I just thought that with the topic name “LifeSize–>Jitsi” people who know the solution for my jibri problem won’t answer there…