Recording failed to start

2022-07-08 06:27:28.925 INFO: [1] MainKt.handleCommandLineArgs#186: Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2022-07-08 06:27:29.504 INFO: [1] MainKt.setupLegacyConfig#211: Checking legacy config file /etc/jitsi/jibri/config.json
2022-07-08 06:27:29.504 INFO: [1] MainKt.setupLegacyConfig#214: Legacy config file /etc/jitsi/jibri/config.json doesn’t exist
2022-07-08 06:27:31.111 INFO: [1] MainKt.main#55: Jibri starting up with id
2022-07-08 06:27:33.942 INFO: [1] JwtInfo$Companion.fromConfig#154: got jwtConfig: {}

2022-07-08 06:27:33.942 INFO: [1] JwtInfo$Companion.fromConfig#164: Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 87: No configuration>
2022-07-08 06:27:34.772 INFO: [1] MainKt.main#125: Using port 3333 for internal HTTP API
2022-07-08 06:27:34.884 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#107: Updating 0 subscribers of status
2022-07-08 06:27:38.043 INFO: [1] XmppApi.updatePresence#203: Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishi>
2022-07-08 06:27:38.087 INFO: [1] XmppApi.start#156: Connecting to xmpp environment on 172.31.45.4 with config XmppEnvironmentConfig(name=nirvana meet, xmppServerHosts=[172.31.45.4], xmppD>
2022-07-08 06:27:38.096 INFO: [1] XmppApi.start#168: The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2022-07-08 06:27:38.218 INFO: [1] MainKt.main#152: Using port 2222 for HTTP API
2022-07-08 06:27:38.224 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient.initializeConnectAndJoin#278: Initializing a new MucClient for [ org.jitsi.xmpp.mucclient.MucClientConfig>
2022-07-08 06:27:38.256 WARNING: [29] MucClient.createXMPPTCPConnectionConfiguration#116: Disabling certificate verification!
2022-07-08 06:27:38.480 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient.initializeConnectAndJoin#340: Dispatching a thread to connect and login.
2022-07-08 06:27:39.111 FINE: [29] JibriStatsDClient.incrementCounter#38: Incrementing statsd counter: xmpp-connected:xmpp_server_host:172.31.45.4
2022-07-08 06:27:39.122 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient$2.connected#311: Connected.
2022-07-08 06:27:39.122 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient.lambda$getConnectAndLoginCallable$7#636: Logging in.
2022-07-08 06:27:39.279 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient$2.authenticated#317: Authenticated, b=false
2022-07-08 06:27:39.392 INFO: [29] [hostname=172.31.45.4 id=172.31.45.4] MucClient$MucWrapper.join#760: Joined MUC: jibribrewery@internal.auth.conference.nirvanameet.com
2022-07-08 06:28:34.655 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#107: Updating 0 subscribers of status

The log is normal and there is no attempt to record. Check jicofo logs.

Please avoid posting in all threads you find. Create one and stick your posts there.

Here my jicofo logs
jicofo.log (40.8 KB)

Jicofo 2022-07-07 06:20:20.751 WARNING: [31] JibriIqHandler.handleRequest#66: Jibri IQ not accepted by any conference: <iq xmlns='jabber:client' to='focus@auth.conference...../f>

You are missing the trusted domain in your jicofo config:

Share your jicofo.conf file.

here my jicofo.conf
jicofo.conf.txt (594 Bytes)

You have an error in your config file.
You have jibri { instead of jibri: {

I do this but still recording failed to start. here my jibri.conf
jibri.conf.txt (2.3 KB)

What is the output on Jibri?

curl --head https://conference.nirvanameet.com

When i run curl --head https://conference.nirvanameet.com then
HTTP/1.1 200 OK
Server: nginx/1.18.0 (Ubuntu)
Date: Fri, 08 Jul 2022 09:12:09 GMT
Content-Type: text/html
Connection: keep-alive
Vary: Accept-Encoding
Strict-Transport-Security: max-age=63072000

but still recording failed

I was commenting about your jicofo config, not jibri config. You need to edit jicofo config.

Edit the jicofo.conf but still recording and live streaming failed to start. In the chrome console the error shown 2022-07-08T09:54:00.042Z [modules/recording/RecordingManager.js] <Object._handleFocusPresence>: Ignoring duplicate presence update: {“error”:“error”,“initiator”:null,“recordingMode”:“file”,“sessionID”:“qiylxgpakhxooqwu”,“status”:“off”}
jicofo.conf.txt (597 Bytes)

What about jicofo logs?

Here my jicofo logs
jibrilog08.txt (13.3 KB)

Have you check it at all?

It says at the end: org.jitsi.jicofo.jibri.JibriSession$StartException$AllBusy: All jibri instances are busy

So there is something wrong with your jibri, check its logs and try fixing that … or it was just busy and you have a single one.
Fix its config if you haven’t, when you edited the wrong file.

I have check that while starting live streaming error shwon live streaming failed to start . In my chrome console 2022-07-08T10:08:02.810Z [modules/RTC/TraceablePeerConnection.js] <Ic.setSenderVideoConstraints>: TPC[id=4,type=JVB] setting max height=0,encodings=[{“active”:false,“adaptivePtime”:false,“maxBitrate”:200000,“networkPriority”:“low”,“priority”:“low”},{“active”:false,“adaptivePtime”:false,“maxBitrate”:700000,“networkPriority”:“low”,“priority”:“low”},{“active”:false,“adaptivePtime”:false,“maxBitrate”:2500000,“networkPriority”:“low”,“priority”:“low”}]
Logger.js:154 2022-07-08T10:08:02.843Z [modules/xmpp/JingleSessionPC.js] <ko.removeRemoteStreamsOnLeave>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] Queued removeRemoteStreamsOnLeave task for participant 13dc30a4
Logger.js:154 2022-07-08T10:08:02.846Z [modules/e2ee/OlmAdapter.js] <hs._onParticipantLeft>: Participant 13dc30a4 left
Logger.js:154 2022-07-08T10:08:02.848Z [JitsiConference.js] <Rl._shouldBeInP2PMode>: P2P? peerCount: 0, hasBotPeer: false => false
Logger.js:154 2022-07-08T10:08:02.848Z [modules/xmpp/JingleSessionPC.js] <Object.callback>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] removeRemoteStreamsOnLeave done!
Logger.js:154 2022-07-08T10:08:22.748Z [modules/xmpp/strophe.jingle.js] <Uo.onJingle>: terminating… 9q5t7fgo0k17a
Logger.js:154 2022-07-08T10:08:22.748Z [modules/xmpp/strophe.jingle.js] <Uo.onJingle>: Received session-terminate from test@conference.conference.nirvanameet.com/focus disconnect reason=Idle session timeout
Logger.js:154 2022-07-08T10:08:22.748Z [modules/xmpp/JingleSessionPC.js] <ko.onTerminated>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] Session terminated expired Idle session timeout
Logger.js:154 2022-07-08T10:08:22.748Z [modules/xmpp/JingleSessionPC.js] <ko.close>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] Clearing modificationQueue
Logger.js:154 2022-07-08T10:08:22.749Z [modules/xmpp/JingleSessionPC.js] <ko.close>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] Queued PC close task
Logger.js:154 2022-07-08T10:08:22.749Z [modules/xmpp/JingleSessionPC.js] <ko.close>: JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] Shutdown modificationQueue!
Logger.js:154 2022-07-08T10:08:22.749Z [JitsiConference.js] <Rl.onCallEnded>: Call ended: expired - Idle session timeout P2P ?false
Logger.js:154 2022-07-08T10:08:22.749Z [JitsiConference.js] <Rl.onCallEnded>: Stopping JVB CallStats
Logger.js:154 2022-07-08T10:08:22.749Z [modules/RTC/TraceablePeerConnection.js] <Ic.close>: TPC[id=4,type=JVB] Closing peerconnection
Logger.js:154 2022-07-08T10:08:22.760Z [modules/xmpp/JingleSessionPC.js] JingleSessionPC[session=JVB,initiator=false,sid=9q5t7fgo0k17a] PC close task done!
Logger.js:154 2022-07-08T10:08:22.761Z [modules/RTC/BridgeChannel.js] <e.onclose>: Channel closed by client
react_devtools_backend.js:4026 2022-07-08T10:08:22.900Z [modules/recording/RecordingManager.js] <Object._handleFocusPresence>: Ignoring duplicate presence update: {“error”:“error”,“initiator”:null,“recordingMode”:“stream”,“sessionID”:“lkjxrtksuelzmdqk”,“status”:“off”}
overrideMethod @ react_devtools_backend.js:4026
r @ Logger.js:154
_handleFocusPresence @ RecordingManager.js:214
onPresence @ RecordingManager.js:60
r.emit @ events.js:153
onPresence @ ChatRoom.js:469
onPresence @ strophe.emuc.js:116
run @ strophe.umd.js:1875
(anonymous) @ strophe.umd.js:3157
forEachChild @ strophe.umd.js:830
_dataRecv @ strophe.umd.js:3146
_onRequestStateChange @ strophe.umd.js:5012
XMLHttpRequest.send (async)
d @ strophe.umd.js:5123
_processRequest @ strophe.umd.js:5137
_throttledRequestHandler @ strophe.umd.js:5290
_onIdle @ strophe.umd.js:4901
_onIdle @ strophe.umd.js:3881
(anonymous) @ strophe.umd.js:5257
setTimeout (async)
_send @ strophe.umd.js:5256
send @ strophe.umd.js:2583
send @ XmppConnection.js:491
onJingle @ strophe.jingle.js:314
run @ strophe.umd.js:1875
(anonymous) @ strophe.umd.js:3157
forEachChild @ strophe.umd.js:830
_dataRecv @ strophe.umd.js:3146
_onRequestStateChange @ strophe.umd.js:5012
XMLHttpRequest.send (async)
d @ strophe.umd.js:5123
_processRequest @ strophe.umd.js:5137
_throttledRequestHandler @ strophe.umd.js:5294
_onIdle @ strophe.umd.js:4901
_onIdle @ strophe.umd.js:3881
(anonymous) @ strophe.umd.js:5257
setTimeout (async)
_send @ strophe.umd.js:5256
send @ strophe.umd.js:2583
sendIQ @ strophe.umd.js:2740
sendIQ @ XmppConnection.js:511
(anonymous) @ XmppConnection.js:525
sendIQ2 @ XmppConnection.js:523
ping @ strophe.ping.js:89
(anonymous) @ strophe.ping.js:120
react_devtools_backend.js:4026 2022-07-08T10:08:22.905Z [modules/recording/RecordingManager.js] <Object._handleFocusPresence>: Ignoring duplicate presence update: {“error”:“error”,“initiator”:null,“recordingMode”:“stream”,“sessionID”:“lkjxrtksuelzmdqk”,“status”:“off”}

I am running jitsi and jibri on same instance in aws t2.large

This cannot handle jibri. You need 4cores and 8GB ram at least for jibri.

Ok Thank you for your valuable time . I will try that with recommended config and let you know.