Recording failed to start

Hi there
I’ve read many topic that deals with this subject and I’m still having trouble recording a meeting.

Here is jibri logs:

2021-10-01 12:17:26.403 FINE: [16] org.jitsi.jibri.util.ProcessStatePublisher.log() Process ffmpeg hasn’t written in 2 seconds, publishing periodic update
2021-10-01 12:17:26.404 INFO: [344] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.log() Ffmpeg quit abruptly. Last output line: plug:bsnoop: Input/output error
2021-10-01 12:17:26.404 INFO: [344] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.log() Ffmpeg capturer transitioning from state Starting up to Error: QuitUnexpectedly SESSION plug:bsnoop: Input/output error
2021-10-01 12:17:26.404 INFO: [344] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() File recording service transitioning from state Starting up to Error: QuitUnexpectedly SESSION plug:bsnoop: Input/output error
2021-10-01 12:17:26.404 INFO: [344] org.jitsi.jibri.api.xmpp.XmppApi.log() Current service had an error Error: QuitUnexpectedly SESSION plug:bsnoop: Input/output error, sending error iq
2021-10-01 12:17:26.405 FINE: [344] org.jitsi.jibri.statsd.JibriStatsDClient.log() Incrementing statsd counter: stop:recording
2021-10-01 12:17:26.405 INFO: [344] org.jitsi.jibri.JibriManager.log() Stopping the current service
2021-10-01 12:17:26.405 INFO: [344] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Stopping capturer
2021-10-01 12:17:26.406 INFO: [344] org.jitsi.jibri.util.JibriSubprocess.log() Stopping ffmpeg process
2021-10-01 12:17:26.408 INFO: [344] org.jitsi.jibri.util.JibriSubprocess.log() ffmpeg exited with value 1
2021-10-01 12:17:26.408 INFO: [344] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Quitting selenium
2021-10-01 12:17:26.409 INFO: [344] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() No media was recorded, deleting directory and skipping metadata file & finalize
2021-10-01 12:17:26.412 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Leaving call and quitting browser
2021-10-01 12:17:26.412 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Recurring call status checks cancelled
2021-10-01 12:17:26.457 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Got 10 log entries for type browser
2021-10-01 12:17:26.525 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Got 435 log entries for type driver
2021-10-01 12:17:26.656 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Got 0 log entries for type client
2021-10-01 12:17:26.657 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Leaving web call
2021-10-01 12:17:26.884 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Quitting chrome driver
2021-10-01 12:17:26.968 INFO: [344] org.jitsi.jibri.selenium.JibriSelenium.log() Chrome driver quit
2021-10-01 12:17:26.969 INFO: [344] org.jitsi.jibri.status.JibriStatusManager.log() Busy status has changed: BUSY → IDLE
2021-10-01 12:17:26.969 FINE: [344] org.jitsi.jibri.webhooks.v1.WebhookClient.log() Updating 0 subscribers of status
2021-10-01 12:17:26.970 INFO: [344] org.jitsi.jibri.api.xmpp.XmppApi.log() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections

Help me with some leads
Thanks in advance

Do you have snd-aloop module?

lsmod | grep aloop

I tried to install it on Ubuntu 20.04 by installing “linux-image-generic” that includes aloop module by default according to community.
But after “lsmod | grep aloop” command i got nothing.

Did you run it as root?

Can you try it again after the following command

modprobe snd-aloop

yes , its on root .

After “modprobe snd-aloop” command i got this
modprobe: FATAL: Module snd-aloop not found in directory /lib/modules/5.11.0-1019-aws

This means that you have no snd-aloop module which is needed by jibri and it seems that your current kernel is not the generic kernel, it’s AWS kernel

So how to resolve it

apt-get install linux-image-generic
It is already updated :-
“linux-image-generic is already the newest version (”

Apply the following commands too

Yes i did it

But did you set it as the default in grub?


I got an error while apt-get purge “linux-imageaws” command
rmdir: failed to remove ‘/lib/modules/5.4.0-1045-aws’: Directory not empty

no problem

Thanks it worked!