Recording ends up in a Screen Share popup

I have installed Jitsi on a Ubuntu server and have setup meeting recording. (Followed the normal guidelines) When I try to start a recording, the process works in a weird manner.

First the ‘Start Recording’ button brings up a new modal.

  1. I cannot uncheck the ‘Save recording file locally’ button.
  2. Also when I continue using ‘Start Recording’ while having ‘Save recording file locally’ checked, the application opens up screen share selection dialog.

Still if I tried to continue by selecting one of the screens Jitsi shows an error saying that it failed to start the recording.

What is this odd behaviour and how can get this working?

I am happy to provide any additional details about the setup.

This happens when either remote recording is disabled, or there are no Jibris available. So in that case only local recording is available. Check that your Jibri is running and that Jicofo can see it (it should log the new brewery instance when Jibri starts up). Also check that you have configured recording correctly:

recordingService: {
  enabled: true
}

The “screen share dialog” is the way the browser asks you for permission to record your screen, the mechanism is the same for screen sharing and for local recording. Unfortunately the browser’s dialog says “wants to share the contents of your screen” which is confusing in this context, but that’s Chrome’s text, not Jitsi’s.

Yeah, we shouldn’t display it when there is a single recording option. Then again, why would you want to toggle it? That would mean you record nothing and I suppose you brought up the recording dialog with some purpose.

This is the expected behavior.

Did you select the tab that matches the meeting?

Sorry for taking time but the issue was because there was no jibri running at the time. I had set up all correctly but for some reason the instance restarted and the jibri service hadn’t started.

But what if I want it to save to a remote server, or S3? I was confused at that part. But the main issue was now resolved. Thanks for replying.