Recording and streaming no working in jitsi server ubuntu 18.04


I currently have a problem, video recording and live streaming is not working.
I have a jitsi self-hosting server on ubuntu 18.04.
The errors I have is “the recording failed to start” or “the broadcast failed to start.”
I tried to modify the interface_config.js file and the you-domain-config.js file but nothing changes. always the same problem

Did you deploy Jibri? You need Jibri for recording and livestreaming. Check out these tutorials:

  1. TUTORIAL - How to Install the NEW JIBRI

  2. [TUTORIAL] Configuration of the New Jibri (1080p Livestreaming and Recording)

Hi Freddie,

I followed your Tutorial (How to Install the New JIBRI , but i same error,
i give more information : my domain server is, my address ip is a ip private ( and the server is VirtuelMachine.
I change “” through “” in file jibri.conf and

I checked in the logs, I can’t find an error related to my recording problem.

Best Regards,



I restart my Jitsi project with the video recording,but i still have the same problem as last time(even following this tuto : TUTORIAL - How to Install the NEW JIBRI and [TUTORIAL] Configuration of the New Jibri (1080p Livestreaming and Recording) ), the only difference is when I click on “start recording”, I have the error “recording failed to start” which arrives after 5 seconds and I have several times to modify the jibri.conf and install jibri.

I change OS by Ubuntu 20.04.

Best regard,

You can try jitsi-jibri installer

Hi emrah,

i try jitsi-jibri installer but i have an error “Aborted! does not point to this server:”.
Currently, i use server local in my network LAN, i not use a resolve name my domain in Internet.

Best Regard

Then you may have

  • self-signed certificate issue
  • harvester issue
  • IP resolving issue by jibri

i use self-signed certificate issue currently in my server, i dont use self-signed certificate for jitsi-jibri installer ?
IP resolving in my server local by file hosts.

jitsi-jibri installer is for the production environment, it’s not suitable for your use case.

When a self-signed certificate used, there should be an extra Chrome flag in jibri.conf to allow it