Reconfigure on Ubuntu

Hi,

I’m used to non-deb distros, but I’ve seen that Jitsi installs quickly on Debian or Ubuntu.
So I’ve launched an xubuntu system and followed the quick guide.
I mistakenly had nginx on the system when I first installed jitsi-meet and wanted apache instead.
So I removed nginx and jitsi-meet with:

$ sudo apt-get remove --auto-remove nginx
$ sudo apt-get purge --auto-remove nginx

Then reinstalled:

$ sudo apt-get -y install jitsi-meet jigasi lua-lpty prosody-modules samba winbind
Reading package lists... Done
Building dependency tree       
Reading state information... Done
lua-lpty is already the newest version (1.0.1-1.1).
prosody-modules is already the newest version (0.0~hg20170929.c53cc1ae4788+dfsg-3).
samba is already the newest version (2:4.7.6+dfsg~ubuntu-0ubuntu2.15).
winbind is already the newest version (2:4.7.6+dfsg~ubuntu-0ubuntu2.15).
jigasi is already the newest version (1.1-91-g203c92a-1).
The following NEW packages will be installed:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge
0 upgraded, 6 newly installed, 0 to remove and 20 not upgraded.
Need to get 68,8 MB of archives.
After this operation, 101 MB of additional disk space will be used.
Get:1 https://download.jitsi.org stable/ jitsi-videobridge 1126-1 [30,4 MB]
Get:2 https://download.jitsi.org stable/ jicofo 1.0-508-1 [32,8 MB]                                      
Get:3 https://download.jitsi.org stable/ jitsi-meet-web 1.0.3729-1 [5.453 kB]                            
Get:4 https://download.jitsi.org stable/ jitsi-meet-web-config 1.0.3729-1 [13,1 kB]                      
Get:5 https://download.jitsi.org stable/ jitsi-meet-prosody 1.0.3729-1 [6.058 B]                         
Get:6 https://download.jitsi.org stable/ jitsi-meet 1.0.4101-1 [2.718 B]                                 
Fetched 68,8 MB in 56s (1.222 kB/s)                                                                      
Preconfiguring packages ...
Selecting previously unselected package jitsi-videobridge.
(Reading database ... 231764 files and directories currently installed.)
Preparing to unpack .../0-jitsi-videobridge_1126-1_amd64.deb ...
Unpacking jitsi-videobridge (1126-1) ...
Selecting previously unselected package jicofo.
Preparing to unpack .../1-jicofo_1.0-508-1_amd64.deb ...
Unpacking jicofo (1.0-508-1) ...
Selecting previously unselected package jitsi-meet-web.
Preparing to unpack .../2-jitsi-meet-web_1.0.3729-1_all.deb ...
Unpacking jitsi-meet-web (1.0.3729-1) ...
Selecting previously unselected package jitsi-meet-web-config.
Preparing to unpack .../3-jitsi-meet-web-config_1.0.3729-1_all.deb ...
Unpacking jitsi-meet-web-config (1.0.3729-1) ...
Selecting previously unselected package jitsi-meet-prosody.
Preparing to unpack .../4-jitsi-meet-prosody_1.0.3729-1_all.deb ...
Unpacking jitsi-meet-prosody (1.0.3729-1) ...
Selecting previously unselected package jitsi-meet.
Preparing to unpack .../5-jitsi-meet_1.0.4101-1_all.deb ...
Unpacking jitsi-meet (1.0.4101-1) ...
Setting up jitsi-videobridge (1126-1) ...
Installing new version of config file /etc/jitsi/videobridge/logging.properties ...
* Applying /etc/sysctl.d/10-console-messages.conf ...
kernel.printk = 4 4 1 7
* Applying /etc/sysctl.d/10-ipv6-privacy.conf ...
net.ipv6.conf.all.use_tempaddr = 2
net.ipv6.conf.default.use_tempaddr = 2
* Applying /etc/sysctl.d/10-kernel-hardening.conf ...
kernel.kptr_restrict = 1
* Applying /etc/sysctl.d/10-link-restrictions.conf ...
fs.protected_hardlinks = 1
fs.protected_symlinks = 1
* Applying /etc/sysctl.d/10-magic-sysrq.conf ...
kernel.sysrq = 176
* Applying /etc/sysctl.d/10-network-security.conf ...
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.tcp_syncookies = 1
* Applying /etc/sysctl.d/10-ptrace.conf ...
kernel.yama.ptrace_scope = 1
* Applying /etc/sysctl.d/10-zeropage.conf ...
vm.mmap_min_addr = 65536
* Applying /etc/sysctl.d/20-jvb-udp-buffers.conf ...
net.core.rmem_max = 10485760
net.core.netdev_max_backlog = 100000
* Applying /usr/lib/sysctl.d/50-default.conf ...
net.ipv4.conf.all.promote_secondaries = 1
net.core.default_qdisc = fq_codel
* Applying /etc/sysctl.d/99-sysctl.conf ...
* Applying /etc/sysctl.conf ...
Setting up jitsi-meet-web-config (1.0.3729-1) ...
----------------

You can now switch to a Let’s Encrypt certificate. To do so, execute:
/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

----------------
Setting up jitsi-meet-web (1.0.3729-1) ...
Setting up jitsi-meet-prosody (1.0.3729-1) ...
Setting up jicofo (1.0-508-1) ...
Setting up jitsi-meet (1.0.4101-1) ...
Processing triggers for ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot
Processing triggers for systemd (237-3ubuntu10.39) ...

Unfortunately, I have not been asked for any configuration parameters.
I also checked that there’s no newly-created apache conf file.

So I also tried:

$ sudo dpkg-reconfigure jitsi-meet
$ sudo debconf-show jitsi-meet

However, no output…

This is probably silly and easy to fix. Any hints?

I just noticed that this command asks me for the certificates but not the FQDN (and does not generate the apache config):

$ sudo dpkg-reconfigure jitsi-meet-web-config

You need to reconfigire all packages that re in the uninstall command as they share values … But I don’t trust reconfigure, safest is purge(follow quick install for uninstall:)) and install again.