Reconfigure new ssl Certificate

I have configured jitsi with valid Godaddy wildcard ssl certificate by using nginx. It works well on web-client. But through app it doesn’t. when i check my ssl certificate by openssl command, i got the error ssl certificate verification issue “Verification error: unable to verify the first certificate”. so i would like to reconfigure ssl certificate alone.please guide me how to do this?

Could you try to add the following lines to the Nginx site config

listen 4445 ssl http2;
listen [::]:4445 ssl http2;

The end result will be

server {
    listen 4444 ssl http2;
    listen [::]:4444 ssl http2;
    listen 4445 ssl http2;
    listen [::]:4445 ssl http2;
    server_name YOUR.DOMAIN.NAME;

And restart the Nginx service.

Hi,
The turn server already listening this port number. so, i could not configured.

I’m suspecting that the protocol mapping in /etc/nginx/modules-enabled/60-jitsi-meet.conf is causing the confusion while checking the SSL certificate, especially for the tools which are using the openssl library.

when i do certificate verification on ssl checker , i am getting following

The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate. But, i have configured.

Are you using the chained certificate?
The certificate containing the site certifcate and the intermediate certificate…

NO, i have configured site certificate only. did not configure chained certificate. how to re-configure with chained certificate.?

@emrah,
I have reconfigured. It is working now. Thank you

1 Like