Random immediately disconnects, still we restart services

Hi Everyone,

I have setup Jitsi in my own environment , Works perfectly. But sometime, Prosody services stops.

This is log from Prosody…

modulemanager: Error initializing module ‘muc’ on ‘example.com’: MUC should be loaded as a component, please see http://prosody.im/doc/components

                                    stack traceback:

                                            /usr/lib/prosody/core/modulemanager.lua:31: in function </usr/lib/prosody/core/modulemanager.lua:31>...

Jul 23 09:30:01 example prosody[21736]: modulemanager: Error initializing module ‘muc_allowners’ on ‘example.com’: /usr/lib/prosody/core/moduleapi.lua:172: Unable to load req…doc/components

                                    stack traceback:

                                            /usr/lib/prosody/core/modulemanager.lua:31: in function </usr/lib/prosody/core/modulemanager.lua:31>...

Jul 23 09:30:01 example prosody[21736]: modulemanager: Unable to load module ‘pinger’: /usr/share/jitsi-meet/prosody-plugins/mod_pinger.lua:52: unexpected symbol near ‘+’

Jul 23 09:30:02 example prosody[21736]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jul 23 09:30:02 example prosody[21736]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Once we restart Prosody, we are not facing this issue since last 8 hours.

Any idea how to solve this?

Regards
Shyam

These you can ignore.

Can you share your prosody config masking sensitive data, as the other errors seems strange.

What does mean prosody stops, the process is not there? What prosody version is that? OS and version? I suppose you are running jitsi-meet(webserver), prosody jicofo and jvb on the same machine what is the available RAM on the machine?