Quick Installation Failed

Tried multiple times.

You need to check why nginx fails. What do you enter as domain name?
If you enter localhost there maybe already virtualhost like that.
Check nginx errors.

domain webrtc.dotfines.com

Nginx

root@webrtc:/home/webrtc_admin# nginx
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()

root@webrtc:/home/webrtc_admin# nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

Oh the domain is visible in the logs :man_facepalming:

Do you have another webserver? What is listening on port 80?

Yes i have another webserver

root@webrtc:/home/webrtc_admin#  netstat -tulpn | grep :80
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      12784/nginx: worker
tcp6       0      0 :::80                   :::*                    LISTEN      12784/nginx: worker

But this is nginx … I don’t get it, you are running two nginx instances on the same machine …

So i preinstalled mistakenly before and after installation it gave errors then i purged everything including nginx and used the quick install …

The ip show the Welcome nginx page while the domain don’t respond :sweat_smile:

Now this again.

root@webrtc:/home/webrtc_admin# nginx -t
nginx: [emerg] host not found in upstream "localhost" in /etc/nginx/sites-enabled/webrtc.dotfines.com.conf:63
nginx: configuration file /etc/nginx/nginx.conf test failed

/etc/nginx/sites-enabled/webrtc.dotfines.com.conf

server_names_hash_bucket_size 64;

server {
    listen 80;
    listen [::]:80;
    server_name webrtc.dotfines.com;

    location ^~ /.well-known/acme-challenge/ {
       default_type "text/plain";
       root         /usr/share/jitsi-meet;
    }
    location = /.well-known/acme-challenge/ {
       return 404;
    }
    location / {
       return 301 https://$host$request_uri;
    }
}
server {
    listen 443 ssl;
    listen [::]:443 ssl;
    server_name webrtc.dotfines.com;

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
    ssl_ciphers "EECDH+ECDSA+AESGCM:EECDH+aRSA+AESGCM:EECDH+ECDSA+SHA256:EECDH+aRSA+SHA256:EECDH+ECDSA+SHA384:EECDH+ECD$
    add_header Strict-Transport-Security "max-age=31536000";

    ssl_certificate /etc/jitsi/meet/webrtc.dotfines.com.crt;
    ssl_certificate_key /etc/jitsi/meet/webrtc.dotfines.com.key;

    root /usr/share/jitsi-meet;

    # ssi on with javascript for multidomain variables in config.js
    ssi on;
    ssi_types application/x-javascript application/javascript;

    index index.html index.htm;
    error_page 404 /static/404.html;

    gzip on;
    gzip_types text/plain text/css application/javascript application/json;
    gzip_vary on;
 location = /config.js {
        alias /etc/jitsi/meet/webrtc.dotfines.com-config.js;
    }

    location = /external_api.js {
        alias /usr/share/jitsi-meet/libs/external_api.min.js;
    }

    #ensure all static content can always be found first
    location ~ ^/(libs|css|static|images|fonts|lang|sounds|connection_optimization|.well-known)/(.*)$
    {
        add_header 'Access-Control-Allow-Origin' '*';
        alias /usr/share/jitsi-meet/$1/$2;
    }

    # BOSH
    location = /http-bind {
        proxy_pass      http://localhost:5280/http-bind;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }
 # xmpp websockets                                                                                                       location = /xmpp-websocket {
        proxy_pass http://127.0.0.1:5280/xmpp-websocket?prefix=$prefix&$args;                                                   proxy_http_version 1.1;                                                                                                 proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_set_header Host $http_host;
        tcp_nodelay on;
    }

    location ~ ^/([^/?&:'"]+)$ {
        try_files $uri @root_path;
    }

    location @root_path {
        rewrite ^/(.*)$ / break;
    }

    location ~ ^/([^/?&:'"]+)/config.js$
    {
       set $subdomain "$1.";
       set $subdir "$1/";
       alias /etc/jitsi/meet/webrtc.dotfines.com-config.js;
    }                                                                                                                   
    #Anything that didn't match above, and isn't a real file, assume it's a room name and redirect to /
    location ~ ^/([^/?&:'"]+)/(.*)$ {
        set $subdomain "$1.";
        set $subdir "$1/";
        rewrite ^/([^/?&:'"]+)/(.*)$ /$2;
    }

    # BOSH for subdomains
    location ~ ^/([^/?&:'"]+)/http-bind {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /http-bind;
    }

    # websockets for subdomains
    location ~ ^/([^/?&:'"]+)/xmpp-websocket {
        set $subdomain "$1.";
        set $subdir "$1/";  
        set $prefix "$1";

        rewrite ^/(.*)$ /xmpp-websocket;
    }                                                                                                                   }

I don’t get it i purged nginx and its still Listening on port 80 …
I used sudo service nginx stop

But its still Listening

@damencho I reinstalled Jitsi meet after removing everything and released port 80 also The installation was successful but its showing the Welcome to nginx page now.
And this error again

root@webrtc:/home/webrtc_admin# nginx -t
nginx: [emerg] host not found in upstream "localhost" in /etc/nginx/sites-enabled/webrtc.dotfines.com.conf:63
nginx: configuration file /etc/nginx/nginx.conf test failed