Provisioning questions

Hello,

I’m discovering Jitsi Desktop 2.10.5550 on Win10.
To me, a very interesting Jitsi feature is its provisioning capability.

  1. Is there a way to trigger provisioning ? GUI says “changes would be taken into account after next restart” but quitting and starting again is not very practical. Is there a better way ?

  2. In my testing, I entered http://myserver/jitsi?user=foo&password=foobar as provisioning URI.
    Both user=foo&password=foobar parameters are passed within POST request content which is fine.
    The issue is this URI remains visible in Jitsi settings.
    How can I hide at least password value (ie foobar in my case) from spying eyes ?

  3. I also tried http://myserver/jitsi?user={user}&password={password} as provisioning URI.
    Both user and password parameters were then not prompted during Jitsi startup.
    Is it expected ?
    From Documentation/Provisionin, I thought I would be prompted to fullfill both.

Best regards

  1. May I add that during this test, the POST requests included:
    user=${user}
    password=

So, no {user} substitution and {password} passed as an empty value.

  1. What is the recommended action for an end user on Windows to clear its current Jitsi settings without changing other users on the same machine, if such exist ?
    I’m asking because I foresee the need to disable access to provisioning settings after successful setup but I would need a way to restart from scratch for any reason.
    That would be the equivalent of Factory Reset for SIP hardphones.

Hi,
not sure if I got your question right but what I can see is that with your provisioning url the sign is missing before {username} and {password}. So the right values for password and user are {username}&password=${password}. Also, using provisioning the described way, the values are transferred as get and not post values. To erase all settings you can just delete the Jitsi folder inside %appdata%

Good luck

@WilhelmB:
Thank you very much for replying.

I also tried using a ${} syntax without being prompted for input.

  1. Have you been prompted, at least once, for login or password or both ?
  2. Can you edit either Username or Password fields content ?

If positive for any of above point 5 or 6, can you describe your Jitsi desktop setup (version, platform, …) ?

Thanks again

Hi,

sure I always get the prompts for username and password. What do you mean by “Can you edit either Username or Password fields content ?” The provisioning string must exactly match https://example.com/provisioning.php?user={username}&password={password} there is nothing to edit or to change, except the hostname and the name of the provisioning script of course.
our setup is Windows 10, Jitsi desktop latest stable build (2.10.5550 I believe)

Cheers

Sorry, I just saw that the forum editor is “eating” the $ sign in front of the variables name. The correct querry must look like the following “https://example.com/provisioning.php?user=${username}&password=${password}” Using exactly this names for the vars will force jitsi to ask you about username and password.

Thank you very much WilhelmB for you help and patience:
changing \${user} to \${username} triggered a connection dialog on next startup !

This connection dialog included:
a Username input
a Password input
and a checkbox to save both.

For those following the same steps, it is worth noting that I had not implemented any provisioning server yet, when studying Jitsi provisioning capabilities.

Thanks again