Provisioning audio settings

Hi,

I’m trying to provision Jitsi Desktop configuration settings. It’s been working fine for several years now, but I’m having issues with these PHP lines Ion the server:

echo 'net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.portaudio.captureDevice_list=["Microphone (USB PnP Sound Device)", "Microphone Array (Intel\u00AE Smart Sound Technology (Intel\u00AE SST))"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.portaudio.notifyDevice_list=["Speakers (USB PnP Sound Device)", "Speakers (Realtek(R) Audio)"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.portaudio.playbackDevice_list=["Speakers (USB PnP Sound Device)", "Speakers (Realtek(R) Audio)"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.automaticgaincontrol=false'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.denoise=false'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.echocancel=false'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.notifyDevice_list=["Speakers (Realtek(R) Audio)", "Speakers (USB PnP Sound Device)"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.captureDevice_list=["Microphone (USB PnP Sound Device)", "Microphone Array (Intel\u00AE Smart Sound Technology (Intel\u00AE SST))"]'."\n";
echo 'net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.playbackDevice_list=["Speakers (USB PnP Sound Device)", "Speakers (Realtek(R) Audio)"]'."\n";

I am expecting the Jitsi Desktop client to set:

net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.captureDevice_list=["Microphone (USB PnP Sound Device)", "Microphone Array (Intel\u00AE Smart Sound Technology (Intel\u00AE SST))"]
net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.playbackDevice_list=["Speakers (USB PnP Sound Device)", "Speakers (Realtek(R) Audio)"]

However, Jitsi Desktop does not honor these two settings and sets:

net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.captureDevice_list=["Microphone Array (Intel\u00AE Smart Sound Technology (Intel\u00AE SST))", "Microphone (USB PnP Sound Device)"]
net.java.sip.communicator.impl.neomedia.audioSystem.wasapi.playbackDevice_list=["Speakers (Realtek(R) Audio)", "Speakers (USB PnP Sound Device)"]

In other words, it seems to be automatically pushing down the USB sound device.

Why do you think this is happening?

Is there a log file on the client and where (to see if it complains about these provisioning lines)?

Thanks