Prosody was unable to find lua-unbound

Dear Jitsi community.

My first post here.

I followed setup instructions on github. Everything went smoothly until I needed to create a user…

sudo prosodyctl register admin jitsi-meet.example.com test1234


Prosody was unable to find lua-unbound
This package can be obtained in the following ways:

Debian/Ubuntu | sudo apt install lua-unbound
luarocks | luarocks install luaunbound

Old DNS resolver library will be used
More help can be found on our website


when I tried to install lua-unbound it says

sudo apt install lua-unbound

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package lua-unbound is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘lua-unbound’ has no installation candidate

And ideas?

Thank you very much.

Br,
kd

@kdiamond Welcome to the community!

I have seen that warning but I found it was okay to ignore it. I am not sure what lua-unbound is for but this is a relatively new message.

There is another related discussion here: XMPP moderator issue with the new prosody (0.12)

  1. Does everything work outside of this warning?

  2. What version of Prosody do you have installed?

  3. Can you also provide a link o the guide you are referencing?

Thank you for Reply @corby

Ubuntu 20.04.4 LTS

  1. Well, just getting to know Jitsi, so can not really tell. It will logon the session. It seems fine so far.
  2. Prosody version 0.12.0-1~focal1
  3. Guide: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet

When I type prosody it will give the error:

root@remote:/home/dali# prosody


Prosody was unable to find lua-unbound
This package can be obtained in the following ways:

Debian/Ubuntu | sudo apt install lua-unbound
luarocks | luarocks install luaunbound
Source | …

Old DNS resolver library will be used
More help can be found on our website, at…


root@remote:/home/dali#

Thank you

Br,
Dali

Ahh yes, now I see!!!

Jitsi Meet is not compatible with Prosody 0.12 at the moment (18-03-2022) please downgrade to Prosody 0.11.

What would be a good way to downgrade prosody?

Current status is:

root@remote:/home/dali# apt list -a prosody
Listing… Done
prosody/unknown,now 0.12.0-1~focal1 amd64 [installed,automatic]
prosody/focal 0.11.4-1 amd64

Thank you

Br,
kd

A simple forum search brought me to:

Did that before I asked.

The next stop when trying to create an user is The given hostname does not exist in the config:

root@remote:/home/dali# sudo prosodyctl register testuser remote.mydomain.com testpass
The given hostname does not exist in the config

hostname is correct.

there is a file /etc/prosody/conf.avail/remote.mydomain.com.cfg.lua

Therefore I asked about the right way to do a downgrade. I’m new to this. Just found out about Prosody today. Sorry for the beginner questions.

Br,
kd

The host definition Prosody is searching for is inside the file(s).
Normally all this is provided for automatically, but when doing funny stuff with Prosody, what can happen is that the path(s) is (are) messed up. Use
sudo prosodyctl about
to find out where the modules and the config live really (Config directory and plugin directories).
You should have something like:

Data directory:     /var/lib/prosody
Config directory:   /etc/prosody
Source directory:   /usr/lib/prosody
Plugin directories:
  /usr/share/jitsi-meet/prosody-plugins/
  /usr/lib/prosody/modules/

check that your config file is referenced by the master config file and that it has a VirtualHost entry with your host name.

When I apply downgrade of prosody things gets bad

  1. sudo apt update
  2. sudo apt install prosody-0.11

Failed to restart prosody.service: Unit prosody.service is masked.
root@remote:/home/dali# systemctl unmask prosody

Then I do unmask

Systemctl unmask prosody

Then I’m again able to restart prosody. But session will stop to show the camera, so I jump into another pool of problems. Luckily I have VM snapshots to jump back at will.

Is there any updated install instructions or even better a prebuit VM with a working Jitsi setup? It’s kind of annoying to setup the system within a few minutes, then struggle for hours making it actually work.

Thank you for your help. It’s greatly appreciated.

Br,
kd

if you use a VM, just restart from scratch, add the 2 PPAs, then sudo apt install prosody-0.11 jitsi-meet. Should work (untested).

Update.

I somehow managed to get it working by selecting N (not to overwrite config) when downgrading Prosody. I hope the newer config (from 0.12) will not haunt me later on somewhere.

Added a user and login the session using a user/password (moderator rights granted). Seems fine now. Have to figure out to invite guests to log in without a password.

Thank you
Br,
kd

1 Like

For completeness sake: I received the same error message Prosody was unable to find lua-unbound [...]. I’m also on Ubuntu 20.04 which apparently does not provide the lua-unbound package. However, I still managed to install it via the luarocks client:

# apt install libunbound-dev liblua5.3-dev
# luarocks install luaunbound

This apparently installed the missing package & i was able to create a user, e.g.

# prosodyctl register foobar meet.example.com password

without the error message you mentioned. I can see the user credential saved in folder /var/lib/prosody/meet%2eexample%2ecom/accounts/foobar.dat

While the unsecured mode works fine, the secure-domain mode still does not work for me. After applying the changes layed out in the handbook however I get an infinite loading reconnect prompt (“You’ve been disconnected”, Rejoin now button, etc.). I am not prompted to authenticate as I would have expected. There are no error logs in neither prosody, jicofo nor jvb log files.

1 Like

The issue may be related in lua version. lua5.2 works.

To check installed lua packages

dpkg -l "lua*" | egrep "^ii"
1 Like

Yea, i’m running lua5.3:

$ dpkg -l "lua*" | egrep "^ii" 
ii  lua-any              25                    all          helper script for shebang lines in Lua scripts
ii  lua-expat:amd64      1.3.0-4               amd64        libexpat bindings for the Lua language
ii  lua-filesystem:amd64 1.7.0-2-1             amd64        luafilesystem library for the Lua language
ii  lua-sec:amd64        0.9-3                 amd64        SSL socket library for the Lua language
ii  lua-socket:amd64     3.0~rc1+git+ac3201d-4 amd64        TCP/UDP socket library for the Lua language
ii  lua5.3               5.3.3-1.1ubuntu2      amd64        Simple, extensible, embeddable programming language
ii  luarocks             2.4.2+dfsg-1          all          deployment and management system for Lua modules 

How can I downgrade lua safely? Sorry for the beginner questions :grimacing:

Edit:

It works! :tada:

I downgraded lua from 5.3 to 5.2. It was quite simple, since there seem to be downward compatibility in all lua libraries concerned. I just ran:

$ apt install lua5.2
$ apt remove lua5.3

Ubuntu then seems to switch seemlessly to lua5.2 … Before:

$ lua
Lua 5.3.3  Copyright (C) 1994-2016 Lua.org, PUC-Rio
> ^C

After

$ lua
Lua 5.2.4  Copyright (C) 1994-2015 Lua.org, PUC-Rio
> ^C

Then I went on to switch the config files to the secure-domain configs for prosody/jitsi meet/jicofo and I realized that I just copy and pasted the default domain name guest.jitsi-meet.example.com etc in 2 of them :person_facepalming:

So yea, it works now (with the lua downgrade), but I can’t tell if it was the lua downgrade responsible for it. Anyway, thank you very much for your input @emrah!

1 Like

Hi kdiamond
I have tried to downgrade prosody to 0.11 by using following command but in vain.
sudo dpkg -i prosody_0.11.4-1_amd64.deb

Pls let me know if this might be wrong command or not as the result was " dpkg: error: cannot access archive ‘prosody_0.11.4-1_amd64.deb’: No such file or directory". Thks in advance for your kind reply.

I found the correct command like " sudo apt install prosody-0.11".

using dpkg directly to do changes is a great way to break your system if you are not very knowledgeable.
You can install package files using apt if you have to. Never force an update if apt warns you against it.
Why can’t you just follow the advice of people reporting success BTW, ie, using lua 5.2 ?