Prosody-trunk installation issue in ubuntu 20.04

I’m trying to implement JWT token in Ubuntu 20.04, but I am unable to install the prosody-trunk, getting dependency errors while running command:
dpkg -i prosody-trunk_1nightly747-1~trusty_amd64.deb

dpkg: dependency problems prevent configuration of prosody-trunk:
 prosody-trunk depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.

Before this I was getting error for lua, somehow I downgraded it from 5.2 to 5.1.

Use prosody-0.11.

This github issue saved my life. Now it’s working fine.