Prosody problem when trying to install jitsi on debian 10


I am trying to install jitsi on a Debian (10) machine using the following documentation:

I had a problem when I tried to add the Prosody package repository

echo deb $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
wget -O- | sudo apt-key add -
apt update

and the following error is output:

E: Failure to fetch 410    Gone             
E: The depot " buster InRelease" is not signed.                                                              
N: Updating such a repository cannot be done in a secure way, so it is disabled by default.          
N: For more details on the creation of package depots as well as their user configuration, see the apt-secure(8) manual page.

Any ideas?

wget -O /tmp/prosody.gpg.key
cat /tmp/prosody.gpg.key | gpg --dearmor >/usr/share/keyrings/prosody-keyring.gpg
echo "deb [signed-by=/usr/share/keyrings/prosody-keyring.gpg] oldstable main" >/etc/apt/sources.list.d/prosody.list

apt-get update
apt-get install lua5.2
apt-get install prosody
1 Like

Dear Emrah,
thx for posting, however after upgrading my own instance (stable version) - since longer time - I still get the error, even after applying your commands:

Hit:5 oldstable InRelease
Hit:6 stable/ InRelease
Reading package lists… Done
E: Failed to fetch 410 Gone [IP: 80]
E: The repository ‘ buster InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any help would be highly appreciated!
kind regards, MS
(not programmer…)

Seems like there is a problem with prosody gpg key.

can I do anything about it?

Did you get any error message while adding GPG key?

Not that I remember (I had to add sudo to execute it), otherwise everything went smoothly except the error message shown above.

According to the warnings, the gpg key of prosody repo is not valid on your system. So it cannot upgrade it.

Dear Emrah,
my Debian server was still on buster, therefore I upgraded now to bullseye.
Then performed purge/reinstall of jitsi-meet and added authorisation etc as usual (all together took maybe 20min), because faced same issue as describe in this thread:

(simply too advanced for me…)

Now upgrading etc worked smoothly, my Jitsi meet instance is running again!
kind regards, MS

1 Like