Prosody module not working | mod_muc_max_occupants

Hi,
I have enabled muc_max_occupants in /etc/prosody/conf.d/mydomain.com.cfg.lua as below but still we can join with more than 3 clients. What am I missing here to limit each session to 3 people?

Module path is already set.

Component “conference.mydomain.com” “muc”
storage = “none”
muc_max_occupants = 3
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
“muc_max_occupants”;
}
admins = { “focus@auth.mydomain.com” }
muc_room_locking = true
muc_room_default_public_jids = false

I am using the prosody 0.10.0-1build1 version.

Also, if I try to hit more users I do not even see related logs in prosody.
Please confirm if i am missing something here to enable this module.

1 Like

you must set muc_access_whitelist (and it should include at least focus@auth.yoururl.yourtld aka jicofo)

1 Like

It worked …thanks :slight_smile: