Prosody log being spammed by "Component warn Component not connected, bouncing error for.."

Today I upgraded jitsi and to jvb2 . Now Prosody is getting spammed with the following every 30 seconds. Any thoughts on how to correct this?   warn    Component not connected, bouncing error for: <iq id='3iXTl-2952' type='get' to='' from=''>

jicofo show

jicofo config looks like this

# Jitsi Conference Focus settings
# sets the host name of the XMPP server

# sets the XMPP domain (default: none)

# sets the secret used to authenticate as an XMPP component

# sets the port to use for the XMPP component connection

# sets the XMPP domain name to use for XMPP user logins

# sets the username to use for XMPP user logins

# sets the password to use for XMPP user logins

# extra options to pass to the jicofo daemon

# adds java system props that are passed to jicofo (default are for home and logging config file)

Thanks for any help you can provide

You can remove that component definition from prosody configs (restart prosody, jvb and then jicofo), now jvb is migrated to use mucs not component.

I had tried that…no luck…I just purged my install and tried to install from scrach…now I really screwed something up!

So, you can try start all from scratch, by uninstalling, deleting /var/lib/prosody contents, restart prosody and install jitsi-meet again.
There is a bug we know about and we are fixing it.

@damencho thanks…now to my next problem…no video when things are going through the videobridge… it doesnt look like its failing back to tcp 4443 (can’t use udp 10000)…any thoughts on that one?

doesn’t seem like anything is listening to 4443… This is a different issue…I’ll create a new thread.

Hi Damencho

This is the exact issue I’m facing, the prosody logs getting this “bounce-error” every 30 seconds
As I understand your answers, this is due to a bug and NOT a configuration error. I quote:

So, you can try start all from scratch, by uninstalling, deleting /var/lib/prosody contents, restart prosody and install jitsi-meet again.
There is a bug we know about and we are fixing it.

Since the system seems to work fine, users(and more than 2) can join rooms etc, I have a few questions

  1. This bug must have an impact somehow? What should we expect not to work?
  2. Should I just leave it alone and wait for a fix?
  3. Is there a definite workaround instead of wiping /var/lib/prosody and reinstalling jitsi-meet. And when you write install jitsi-meet again do you mean something like: sudo apt --reinstall install jitsi-meet.
    I’m not so fond of tearing everything down, since the system is being used - but maybe not so much in the week-end…
    Hans Otto

If it works for you, then you did not hit any bug.

You can remove the component definition from prosody if it is not used.

Hey, just interested (as I get the same error, and same as you everything working nonetheless) why you are looking at the jicofo while the error message states that jitsi-videobridge is throwing the error (as far as I understand). Is it because at the end of the error message the “from” states ‘focus@auth…’?

I get no error messages in my /var/log/jitsi/jicofo.log, only the info that successfull health checks where performed.

There is another thread here where the error message states: warn Component not connected, bouncing error for: <iq id='gEXV7-53' type='get' to='' from=''>
I get this specific error only once, when I start the jicofo service (after starting prosody and jvb, in this order).

[Edit] Oops, I removed the component definition by commenting out the segment Component "" from /etc/prosody/conf.avail/ instead of Component ""… that got me errors in the prosody.log I specified here before the edit, now it’s working and the component error is not showing anymore. [/Edit]

To all: How should the /etc/jitsi/videobridge/config look like? Should there be this options:
Or are the credentials only needed in /etc/jitsi/videobridge/ as
because JVB uses now MUCS instead of Component?

Hi @MerlinZero

I am using JVB2, and my /etc/jitsi/videobridge/config looks like this:





JAVA_SYS_PROPS=" - - - java.util.logging.config.file=/etc/jitsi/videobridge/"

I hope this helps you

Thanks :slight_smile: So no AUTH_USER and AUTH_PASSWORD in /etc/jitsi/videobridge/config :+1:


I have installed Jitsi-Meet in VM with Ubuntu20.04 in private IP. While connecting, getting the following error.

component warn Component not connected, bouncing error for:

Please suggest.

1 Like

hi u, did u resolve your error? thanks