Prosody log being spammed by "Component warn Component not connected, bouncing error for.."

Today I upgraded jitsi and to jvb2 . Now Prosody is getting spammed with the following every 30 seconds. Any thoughts on how to correct this?

jitsi-videobridge.jitsi.domain.com:component   warn    Component not connected, bouncing error for: <iq id='3iXTl-2952' type='get' to='jitsi-videobridge.jitsi.domain.com' from='focus@auth.jitsi.domain.com/focus357666649775'>

jicofo sip.properties show
org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.jitsi.domain.com

jicofo config looks like this

# Jitsi Conference Focus settings
# sets the host name of the XMPP server
JICOFO_HOST=localhost

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=jitsi.domain.com

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=password1234

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.jitsi.domain.com

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=password5678

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/v$

Thanks for any help you can provide

You can remove that component definition from prosody configs (restart prosody, jvb and then jicofo), now jvb is migrated to use mucs not component.

I had tried that…no luck…I just purged my install and tried to install from scrach…now I really screwed something up!

So, you can try start all from scratch, by uninstalling, deleting /var/lib/prosody contents, restart prosody and install jitsi-meet again.
There is a bug we know about and we are fixing it.

@damencho thanks…now to my next problem…no video when things are going through the videobridge… it doesnt look like its failing back to tcp 4443 (can’t use udp 10000)…any thoughts on that one?

doesn’t seem like anything is listening to 4443… This is a different issue…I’ll create a new thread.

Hi Damencho

This is the exact issue I’m facing, the prosody logs getting this “bounce-error” every 30 seconds
As I understand your answers, this is due to a bug and NOT a configuration error. I quote:

So, you can try start all from scratch, by uninstalling, deleting /var/lib/prosody contents, restart prosody and install jitsi-meet again.
There is a bug we know about and we are fixing it.

Since the system seems to work fine, users(and more than 2) can join rooms etc, I have a few questions

  1. This bug must have an impact somehow? What should we expect not to work?
  2. Should I just leave it alone and wait for a fix?
  3. Is there a definite workaround instead of wiping /var/lib/prosody and reinstalling jitsi-meet. And when you write install jitsi-meet again do you mean something like: sudo apt --reinstall install jitsi-meet.
    I’m not so fond of tearing everything down, since the system is being used - but maybe not so much in the week-end…
    Hans Otto

If it works for you, then you did not hit any bug.

You can remove the component definition from prosody if it is not used.

Hey, just interested (as I get the same error, and same as you everything working nonetheless) why you are looking at the jicofo sip-communicator.properties while the error message states that jitsi-videobridge is throwing the error (as far as I understand). Is it because at the end of the error message the “from” states ‘focus@auth…’?

I get no error messages in my /var/log/jitsi/jicofo.log, only the info that successfull health checks where performed.

There is another thread here where the error message states:
focus.mydomainhere.com:component warn Component not connected, bouncing error for: <iq id='gEXV7-53' type='get' to='focus.mydomainhere.com' from='focus@auth.mydomainhere.com/focus6292778556840'>
I get this specific error only once, when I start the jicofo service (after starting prosody and jvb, in this order).

[Edit] Oops, I removed the component definition by commenting out the segment Component "focus.jitsi.domain.com" from /etc/prosody/conf.avail/jitsi.domain.com.cfg.lua instead of Component "jitsi-videobridge.jitsi.domain.com"… that got me errors in the prosody.log I specified here before the edit, now it’s working and the component error is not showing anymore. [/Edit]

To all: How should the /etc/jitsi/videobridge/config look like? Should there be this options:
JVB_AUTH_DOMAIN=auth.jitsi.domain.com
JVB_AUTH_USER=jvb
JVB_AUTH_PASSWORD=passwordxyz
Or are the credentials only needed in /etc/jitsi/videobridge/sip-communicator.properties as
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.jitsi.domain.com
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=passwordxyz
because JVB uses now MUCS instead of Component?

Hi @MerlinZero

I am using JVB2, and my /etc/jitsi/videobridge/config looks like this:

JVB_HOSTNAME=my.jitsi.site

JVB_HOST=

JVB_PORT=5347

JVB_SECRET=password

JVB_OPTS="–apis=,"

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi - net.java.sip.communicator.SC_HOME_DIR_NAME=videobridge - net.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi - java.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

I hope this helps you

Thanks :slight_smile: So no AUTH_USER and AUTH_PASSWORD in /etc/jitsi/videobridge/config :+1: