Prosody install on Debian 10

Hi,

I allready install jitsi-meet.
Now i will install the JWT auth. I found a little howto https://community.jitsi.org/t/error-during-jitsi-meet-tokens-installation/21636/2?u=vapaa but i dosn’t work.

I am stuck installing luacrypto and get the following error:

root@testlab:/opt/luacrypto# luarocks make
Warning: unmatched variable INCONCERT_DEVEL
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
CRYPTO_LIBRARY
    linked by target "crypto" in directory /opt/luacrypto
OPENSSL_INCLUDE_DIR
   used as include directory in directory /opt/luacrypto
   used as include directory in directory /opt/luacrypto
   used as include directory in directory /opt/luacrypto
   ...
   used as include directory in directory /opt/luacrypto
SSL_LIBRARY
    linked by target "crypto" in directory /opt/luacrypto

-- Configuring incomplete, errors occurred!
See also "/opt/luacrypto/build.luarocks/CMakeFiles/CMakeOutput.log".

Error: Build error: Failed cmake.

Best regard

Hi, can you show the log ?

Hi,

sure …
CMakeOutput.log (15.7 KB)

Thanks

Hi,
can anybody help?

Thanks

Hello, everybody,
where can I report this bug so it can be fixed. Because this is not the way to run the software on the internet.

Thanks and greetings
vapaa