Prosody error when installing on Ubuntu 20

Dear friends,

I am trying to install Jitsi on my Ubuntu 20.04.5 VPS server, and I am stuck at this error (I have read a few other topics here but they don’t seem to fix the issue):

The following information may help to resolve the situation:

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.6854-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.6854-1) but it is not going to be installed

I have tried the suggestions in this topic

but I still cannot get past the hurdle.

I appreciate any help you may give me and thank you all in advance.

I apologise, I just realised, reading the self-hosting instructions again that I had missed the step for the installation of the prosody repo.

After doing that it has installed successfully.