Prosody containers config file keeps reseting

Prosody config file keeps reseting everytime I run docker-compose.
I tried changing the files at ~/.jitsi-meet-cfg/prosody and at the root docker directory.
The changes do not stick.
I would like to implement these settings in the prosody lua file:
cross_domain_websocket = true;
consider_websocket_secure = true;
Any ideas?

I am stuck there as well. Any luck overcoming this?

Yes I solved this by removing the following line in docker-compose.yml:

image: jitsi/prosody:latest

and replaced it with:

build: ./prosody

This change makes it so the docker container is build from the host docker jitsi meet directory (prosody directory).
So the changes you make in the host file system inside prosody directory will be also in the prosody container.
P.S: If you want to change once again later after said changes were made and container was ran, you will have to remove the built docker image.

Thank you for your reply. If I understand you correctly, the only way to stop parsody files from getting reset is to build a docker image?

Yes to build an image from host prosody config.
It’s a solution and it works but it’s definitely not the only option.
I don’t know why devs don’t want to help with this issue or just give an option for config files to not reset everytime…