Prosody confiruration for jibri

I am trying to registers jibri users on prosody and I am getting the error:

root@jitsilokdon:~# prosodyctl register recorder recorder.jitsi.jitsilokdon.com jibrirecorderpass
modulemanager error Unable to load module ‘auth_internal plain’: /usr/lib/prosody/modules/mod_auth_internal plain.lua: No such file or directory
Error: Method not implemented

have you checked in the path? did the “/usr/lib/prosody/modules/mod_auth_internal plain.lua” file exist ?

It does exist…

See the diagram it does

Can someone help me here thanks.

Are you still interested in helping here. Thanks

Try to add /usr/lib/prosody/modules/ to /etc/prosody/prosody.cfg.lua as module directory.

add just like that: How do I do this please.

this is module_enabled. Where do I put the /usr/lib/prosody/mod_auth_internal_plain.lua


modules_enabled = {

    -- Generally required
            "roster"; -- Allow users to have a roster. Recommended ;)
            "saslauth"; -- Authentication for clients and servers. Recommended if you want to log in.
            "tls"; -- Add support for secure TLS on c2s/s2s connections
            "dialback"; -- s2s dialback support
            "disco"; -- Service discovery

    -- Not essential, but recommended
            "carbons"; -- Keep multiple clients in sync
            "pep"; -- Enables users to publish their mood, activity, playing music and more
            "private"; -- Private XML storage (for room bookmarks, etc.)
            "blocklist"; -- Allow users to block communications with other users
            "vcard"; -- Allow users to set vCards

    -- Nice to have
            "version"; -- Replies to server version requests
            "uptime"; -- Report how long server has been running
            "time"; -- Let others know the time here on this server
            "ping"; -- Replies to XMPP pings with pongs
            "register"; -- Allow users to register on this server using a client and change passwords
            --"mam"; -- Store messages in an archive and allow users to access it

    -- Admin interfaces
            "admin_adhoc"; -- Allows administration via an XMPP client that supports ad-hoc commands
            --"admin_telnet"; -- Opens telnet console interface on localhost port 5582

    -- HTTP modules
            --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
            --"websocket"; -- XMPP over WebSockets
            --"http_files"; -- Serve static files from a directory over HTTP

    -- Other specific functionality
            "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
            --"limits"; -- Enable bandwidth limiting for XMPP connections
            --"groups"; -- Shared roster support
            --"server_contact_info"; -- Publish contact information for this service
            --"announce"; -- Send announcement to all online users
            --"welcome"; -- Welcome users who register accounts
            --"watchregistrations"; -- Alert admins of registrations
            --"motd"; -- Send a message to users when they log in
            --"legacyauth"; -- Legacy authentication. Only used by some old clients and bots.
            --"proxy65"; -- Enables a file transfer proxy service which clients behind NAT can use

}

– These modules are auto-loaded, but should you want
– to disable them then uncomment them here:

plugin_paths = { "/path/to/modules", "/path/to/more/modules" }

Like this->
plugin_paths = { “/path/to/modules”, “/usr/lib/prosody/modules/” }

I copied accordingly and still same issues.

I see… you have put space between internal and plain, it should be “internal_plain”, your error says ‘auth_internal plain’ , notice the space.

plugin_paths = { “/path/to/modules”, “/usr/lib/prosody/modules/mod_auth_internal_plain.lua” }

Is this how I should put it then.

Help if you can were do I put those this modules extentsions?

This does not work for me.

Let me know if we can connect remotely. Nothing wrong with plugin modules, your domain config seems wrong.

I have one domain jitsilokdon.com I made sure when people want to use riot they can always go to matrix.jitsilokdon.com (modified the json to always point to the marix.jitsilokdon. Then I have riot.jitsilokdon.com … This is for the web client … Finally I have jitsi.jitsilokdon.com for video conferencing. All this put together is a full blown video conference solution. However I need to stream and record the meetings. I went ahead to install jibri on jitsi.

root@jitsilokdon:~# prosodyctl register recorder recorder.jitsi.jitsilokdon.com jibrirecordpass
This addition to the prosody does not work.

root@jitsilokdon:~# prosodyctl register jibri auth.jitsi.jitsilokdon.com jibrirauthpass
This one works it was added.