Prosody Admin Web with Jitsi

Hi I’ve succeeded in getting Jitsi Meet up and running on a VPS, and all is working as great!

I’m now attempting to install a prosody module ‘admin_web’ according to this guide, https://modules.prosody.im/mod_admin_web.html to allow me a GUI way to manage users (I’ve set Jicofo with a secure domain for starting meetings).

As per the instructions I’ve;

  1. copied the ‘mod_admin_web’ module folder to /usr/share/jitsi-meet/prosody-plugins,
  2. navigated into /usr/share/jitsi-meet/prosody-plugins/mod_admin_web/admin_web
  3. executed get_deps.sh from within that director, with root permissions.
  4. edited ‘/etc/prosody/conf.avail/meet.mydomain.co.uk.cfg.lua’ to add ‘admin_web’ to 'modules_enabled
  5. allowed port 5280 through the firewall

All the above processes appear to work, however navigating to meet.mydomain.co.uk:5280/admin takes several minutes attempting to load, before generating a ‘this site can’t be reached…took too long to respond’ message in the browser.

Any help as to what I’ve misconfigured or missed out would be greatly appreciated!

3 Likes

First check if there’s something listening on the port 5280

Did you reconfigured and reloaded prosody service?

How do you mean check if there’s something listening?
I know the port is open as going to meet.mydomain.co.uk:5280/http-bind shows me the prosody/BOSH “it works” message.

I have reloaded and restarted prosody, and restarted the entire server since changing config with no success.

SOLVED!

It appears it was potentially a caching issue on my local machine… I have just restarted my local machine for other reasons, and it now works!

@borderlander TIP for future: always try in incognito mode while testing to avoid caching.

I’m trying to install too the module, could you rewrite the step by step procedure to help me a bit and others? It would be a kudish thing :slightly_smiling_face:

I am getting this error… any idea why?

@Mohamed_Rahees how did you add the admin account?

@borderlander do you know how to add the admin account?

Hi,

I did the quick install of Jitsi and did exactly like @borderlander (even if the 5280 is redirected by nginx on 443).

I don’t understand what is wrong… maybe something missing in the nginx.conf ?

Thanks for your help!

What I did in my Jitsi Meet installation on Debian 10:

Prosody Virtual host: jitsi.yourdomain.com

  1. No need to change nginx conf

  2. In /etc/prosody/conf.avail/jitsi.yourdomain.com.cfg.lua:

before VirtualHost “jitsi.yourdomain.com add:

http_ports = { 5280 }
http_interfaces = { “*”, “::” }

https_ports = { 5281 }
https_interfaces = { “*”, “::” }
https_certificate = “certs/jitsi.yourdomain.com.crt”

  1. Open port 5281 on your firewall

  2. You can access prosody admin web now at:

4.1 NOT recommended: http://jitsi.yourdomain.com:5280/admin
4.2 RECOMMENDED: https://jitsi.yourdomain.com:5281/admin

2 Likes

Thanks but you didn’t take the part “Quick Install”

I already have a Jitsi install working so no need to open port 5281 (which is redirected to 80)

So you gave me something useless!

I make it work adding this to my nginx .conf file :

location ~ ^/admin/(.*)$ {
    add_header 'Access-Control-Allow-Origin' '*';
    alias /usr/share/jitsi-meet/prosody-plugins/www_files/$1;
}

After, I had to add my account in “admins” to my .cfg.lua :

admins = { "blabla@mydomain.com" }

And finally, had to change the first line to ‘main.js’ in www_files :

var BOSH_SERVICE = '/http-bind/' ;

to

var BOSH_SERVICE = '/http-bind' ;

If someone is in my case “Quick Install” Jitsi… maybe there is a better solution but this one is working!

Thanks @nscomputing It works. And after more tries. I can confirm that the only thing you need to activate https after installing mod_admin_web is adding this line before VirtualHost "jitsi.yourdomain.com"
https_certificate = "certs/jitsi.yourdomain.com.crt"

Hi @nake36 I follow “Quick Install” & did this & works without need to edit nginx.conf

1 Like

Hi,

Could you please explain how to install mod_admin? I’ve already try with the following order:

  1. install prosody modules with this command: hg clone https://hg.prosody.im/prosody-modules/ prosody-modules
    and copying mod_admin_web module to /usr/share/jitsi-meet/prosody-plugins

  2. adding this configuration in /etc/prosody/conf.avail/mydomain.com (before VirtualHost “mydomain.com” :
    https_ports = { 5281 }
    https_interfaces = { “*”, “::” }
    https_certificate = “certs/mydomain.com.crt”

  3. ufw allow 5281 and ufw reload

but it always failed when restart the prosody service.

Thanks a lot

Did you find a solution for this?
I am experiencing the same problem.

image

Have you done this steps:

  • navigated into /usr/share/jitsi-meet/prosody-plugins/mod_admin_web/admin_web
  • executed get_deps.sh from within that director, with root permissions.

then
adding this configuration in /etc/prosody/conf.avail/mydomain.com (before VirtualHost “mydomain.com” :
https_certificate = “certs/mydomain.com.crt”

if so, please put here the output of systemctl status prosody

Hi @Fahad9214,

I try to follow your suggestion, but i’m still get error at prosody restart, here is the output of systemctl status prosody:

● prosody.service - LSB: Prosody XMPP Server
Loaded: loaded (/etc/init.d/prosody; generated)
Active: failed (Result: exit-code) since Tue 2020-05-05 23:02:50 UTC; 23s ago
Docs: man:systemd-sysv-generator(8)
Process: 8524 ExecStop=/etc/init.d/prosody stop (code=exited, status=0/SUCCESS)
Process: 25387 ExecReload=/etc/init.d/prosody reload (code=exited, status=0/SUCCESS)
Process: 8837 ExecStart=/etc/init.d/prosody start (code=exited, status=1/FAILURE)

May 05 23:02:50 mydomain.org prosody[8837]: **************************
May 05 23:02:50 mydomain.org prosody[8837]: A problem occured while reading the config file /etc/prosody/prosody.cfg.lua
May 05 23:02:50 mydomain.org prosody[8837]: [86B blob data]
May 05 23:02:50 mydomain.org prosody[8837]: More help on configuring Prosody can be found at http://prosody.im/doc/configure
May 05 23:02:50 mydomain.org prosody[8837]: Good luck!
May 05 23:02:50 mydomain.org prosody[8837]: **************************
May 05 23:02:50 mydomain.org prosody[8837]: …fail!
May 05 23:02:50 mydomain.org systemd[1]: prosody.service: Control process exited, code=exited status=1
May 05 23:02:50 mydomain.org systemd[1]: prosody.service: Failed with result ‘exit-code’.
May 05 23:02:50 mydomain.org systemd[1]: Failed to start LSB: Prosody XMPP Server.

Please advice,

Thanks

Please check your configuration with:

prosodyctl check config

make sure that you use ("") instead of (“”) in config file.
I noticed this in the config above and it is automatically converted by forum editor which is wrong.

Thanks for giving this suggestion, the prosody services restart are working now

Yes, exactly, this solve my problem & i was able to restart prosody service succesfully.
But i still cannot access web admin page, is there any additional steps that i’ve missed?

Please advice… :pray:

Thanks

Please check if “admin_web” module is enabled in your virtual host “mydomain.com” and module “bosh” in /etc/prosody/prosody.cfg.lua .