Prosoday mod_spakeaser jitsi not detected

Hello,

I tried to make a module:log to see the data displayed when the user enters the room or when he leaves using the module mod_spakeaser but there is nothing detected

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “meet.test.dev”;

external_service_secret = “mT4MtdWgoN1kb”;
external_services = {
{ type = “stun”, host = “meet.test.dev”, port = 3478 },
{ type = “turn”, host = “meet.test.dev”, port = 3478, transport = “udp”, secret = true, ttl = 86400, algorithm = “turn” },
{ type = “turns”, host = “meet.test.dev”, port = 5349, transport = “tcp”, secret = true, ttl = 86400, algorithm = “turn” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
– https_ports = { }; – Remove this line to prevent listening on port 5284

– by default prosody 0.12 sends cors headers, if you want to disable it uncomment the following (the config is available on 0.12.1)
–http_cors_override = {
– bosh = {
– enabled = false;
– };
– websocket = {
– enabled = false;
– };
–}

Mozilla SSL Configuration Generator
ssl = {
protocol = “tlsv1_2+”;

}

unlimited_jids = {
“focus@auth.meet.test.dev”,
“jvb@auth.meet.test.dev”
}

VirtualHost “meet.test.dev”
– enabled = false – Remove this line to enable this host
authentication = “anonymous”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/meet.test.dev.key”;
certificate = “/etc/prosody/certs/meet.test.dev.crt”;
}
av_moderation_component = “avmoderation.meet.test.dev”
speakerstats_component = “speakerstats.meet.test.dev”
conference_duration_component = “conferenceduration.meet.test.dev”
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“external_services”;
“conference_duration”;
“muc_lobby_rooms”;
“muc_breakout_rooms”;
“av_moderation”;
}
c2s_require_encryption = false
lobby_muc = “lobby.meet.test.dev”
breakout_rooms_muc = “breakout.meet.test.dev”
main_muc = “conference.meet.test.dev”
– muc_lobby_whitelist = { “recorder.meet.test.dev” } – Here we can whitelist jibri to enter lobby enabled rooms

Component “conference.meet.test.dev” “muc”
restrict_room_creation = true
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
“polls”;
–“token_verification”;
“muc_rate_limit”;
}
admins = { “focus@auth.meet.test.dev” }
muc_room_locking = false
muc_room_default_public_jids = true

Component “breakout.meet.test.dev” “muc”
restrict_room_creation = true
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
–“token_verification”;
“muc_rate_limit”;
“polls”;
}
admins = { “focus@auth.meet.test.dev” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.meet.test.dev” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.meet.test.dev”, “jvb@auth.meet.test.dev” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.meet.test.dev”
ssl = {
key = “/etc/prosody/certs/auth.meet.test.dev.key”;
certificate = “/etc/prosody/certs/auth.meet.test.dev.crt”;
}
modules_enabled = {
“limits_exception”;
}
authentication = “internal_hashed”

– Proxy to jicofo’s user JID, so that it doesn’t have to register as a component.
Component “focus.meet.test.dev” “client_proxy”
target_address = “focus@auth.meet.test.dev”

Component “speakerstats.meet.test.dev” “speakerstats_component”
muc_component = “conference.meet.test.dev”

Component “conferenceduration.meet.test.dev” “conference_duration_component”
muc_component = “conference.meet.test.dev”

Component “avmoderation.meet.test.dev” “av_moderation_component”
muc_component = “conference.meet.test.dev”

Component “lobby.meet.test.dev” “muc”
storage = “null”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true
modules_enabled = {
“muc_rate_limit”;
“polls”;
}

– Enabled dial-in for JaaS customers
– Note: make sure you have the following packages installed: lua-basexx, liblua5.3-dev, libssl-dev, luarocks
– and execute $ sudo luarocks install luajwtjitsi 3.0-0
VirtualHost “jigasi.meet.jitsi”
enabled = false – JaaS customers remove this line
modules_enabled = {
“ping”;
“bosh”;
}
authentication = “token”
app_id = “jitsi”;
asap_key_server = “https://jaas-public-keys.jitsi.net/jitsi-components/prod-8x8
asap_accepted_issuers = { “jaas-components” }
asap_accepted_audiences = { “jigasi.meet.test.dev” }

any help please

Is it working at all in jitsi-meet? Open a conference with 3 participants and change the dominant speaker from time to time by muting the other two and have just one unmuted … then enter with a fourth or reload one of the participants, after joining is speaker stats updated to show almost the similar values as what the participants that are still in the conference see.

yes it’s good

i have on question when i join a room as a first user I am not the admin even the other users are not admin i.e. room without admin so I can’t record do you have an idea please

Depending on your setup, with the default config jicofo sets a moderator for the first user joining.
Open a new thread about it posting your jicofo config.

About the speaker stats. Did you restart prosody after your change?
Are you editing the file in /usr/share/jitsi-meet/prosody-plugins/?
Where did you add the print?

yes for speaker i juste restart prosody it’s working thanks