Prompt for guest to enter their names

Hi All,

Does anyone know to how to enforce a guest user to enter their name before joining. I would prefer that for identification as opposed to “Fellow Jitster” by default.

Thank you in advance for your feedback.

Thank you for the quick reply Damian.

Hi Damian,

in my Jitsi-Configuration I set that the first user in the role as moderator has to log in with username and password (the user has been created by prosodyctl register - command previously) and the next users have to know the password, given by the moderator. I enabled the setting as you have shown “requireDisplayName: true”

My two Problems:

  1. In the conference, the first user is still shown with the Name “Me” (comes from the Variable DEFAULT_LOCAL_DISPLAY_NAME-Value in the interface_config.js - File) and not with its login-name. He also is not asked by his Real name, in case of the system should differentiate between the login-name and the name to show.
  2. Even though I set the “requireDisplayName” to “true”, all users that come to the meetingroom after the moderator were not asked by their name. As the name, Jitsi shows the value of the variable “DEFAULT_REMOTE_DISPLAY_NAME” in the interface_config.js - File.

Do you know, why the reqireDisplayName-entry has no effect?

Thanks in advance for your support.

We’re having the same problem, can you give us some advice?

We have no registered users on prosody, but we set requireDisplayName to true and it is still not working.

Our project was installed from source (I don’t know if it can affect).

Is there anything else that needs to be done?

Thanks in advance

EDIT: I detected that I was modifying the incorrect config.js file. I modified the file on nginx configuration, and now it is working fine.

1 Like

works for me (except if the user as already set up a name of course)

An alternative way to solve this is to give each user an url with the desired username and email set in the URL.

I have a registration page using wordpress forms where the users enter their name and email. This registration page then generate an unique URL for each user with the name and email set, so that when the user join everything is in order.
example URL with username and email set:


@FernandoSP I trust you are well. I am new to Jitsi and Linux, I am having the same problem you had regarding “requireDisplayName to true” can please help me with the path to get to Nginx configuration? Thank you

Hi @damencho is it possible to prevent “Prompt for guest to enter their names” when I am using Jisti API. ( embedded one) ?

1 Like

i have done this but still getting this screen

waiting for you reply @damencho Sir

Add it in config overwrite, not interface config

1 Like

It works, Thank you very much. Before leaving I just want you to this question? Is there any option to remove top-left Jitsi logo when anyone using JITSI API ( embedded one) @damencho

You can on your hosted deployment with a setting in interface config.

If you are asking about, the answer is no and removing the logo violates the terms of service.