Problems with P2P

Hi. I have a setup with 1 jitsi-meet server, 1 turn-server and 4 videobridges. When I start a meeting with 1 guest both using Safari I can’t get a p2p connection. If I use Chrome it works. Then I tried Safari with meet.jit.si and it also didn’t connect with p2p. Here too Chrome works.
meet.jit.si shows my internal IP adresses with p2p. In my setup I see the IP of my turn-server. What could be the cause for this? Which config did I get wrong? Is the turn-server causing this?

What do you see when there are 3+ participants?

Then I see an IP from my videobridges.

This may be related in p2p.stunServers which is in your /etc/jitsi/meet/jitsi.yourdomain.com-config.js

I tried my own server and { urls: ‘stun:meet-jit-si-turnrelay.jitsi.net:443’ } but there was no difference.

Are you connecting from a place that is close to the turnserver?

And is this enabled jitsi-meet/config.js at eb720d5ddcdc14c4e78f41185f38c93a772f07ed · jitsi/jitsi-meet · GitHub ?

Our Turn-Server is about 130 km away from me.
// useTurnUdp: false - is not enabled

thanx emrah and damencho for your replies. In the meantime I have tried sooo many different settings and now I see my internal IPs with p2p. Please don’t ask me, what did the trick. I have no idea.

1 Like