Problema no jibri

Estou a alguns dias tendo dor de cabeça para configurar o jibri para realizar gravação das conferências, só dá falha.

A conferência está funcionando normal, só dá erro para gravar.

Minhas configurações:

{
“recording_directory”:"/srv/recordings",
“finalize_recording_script_path”: “/srv/scripts”,
“xmpp_environments”: [
{
“name”: “prod environment”,

        "xmpp_server_hosts": [
            "aprovaead.live"
        ],
        "xmpp_domain": "aprovaead.live",
        "control_login": {
            "domain": "auth.aprovaead.live",
            "username": "jibri",
            "password": "aprovaead"
        },
        "control_muc": {
            "domain": "internal.auth.aprovaead.live",
            "room_name": "JibriBrewery",
            "nickname": "jibri-nickname"
        },
        "call_login": {
            "domain": "recorder.aprovaead.live",
            "username": "recorder",
            "password": "aprovaead"
        },
        "room_jid_domain_string_to_strip_from_start": "conference.",
        "usage_timeout": "0"
    }
]

}

ATUALIZEI MEU JAVA PARA JAVA 8 E AGORA O ERRO ALTEROU

O erro:

JibriConfig(recordingDirectory=/srv/recordings, singleUseMode=false, enabledStatsD=true, finalizeRecordingScriptPath=/srv/webhook.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[aprovaead.live], xmppDomain=aprovaead.live, controlLogin=XmppCredentials(domain=auth.aprovaead.live, username=jibri, password=aprovaead), controlMuc=XmppMuc(domain=internal.auth.aprovaead.live, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.aprovaead.live, username=recorder, password=aprovaead), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)])
2020-05-08 07:23:25.170 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2020-05-08 07:23:25.438 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-05-08 07:23:25.440 INFO: [1] org.jitsi.xmpp.mucclient.MucClientManager.log() Setting a presence extension: org.jitsi.xmpp.extensions.jibri.JibriStatusPacketExt@5b989dc7
2020-05-08 07:23:25.447 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on aprovaead.live with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[aprovaead.live], xmppDomain=aprovaead.live, controlLogin=XmppCredentials(domain=auth.aprovaead.live, username=jibri, password=aprovaead), controlMuc=XmppMuc(domain=internal.auth.aprovaead.live, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.aprovaead.live, username=recorder, password=aprovaead), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2020-05-08 07:23:25.448 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-05-08 07:23:25.467 WARNING: [20] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-05-08 07:23:25.521 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2020-05-08 07:23:25.746 INFO: [20] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=aprovaead.live hostname=aprovaead.live] connected
2020-05-08 07:23:25.815 INFO: [20] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal.auth.aprovaead.live

Eu resolvi meu problema utilizando o código abaixo:

apt install jicofo=1.0-481-1 jitsi-meet=1.0.3936-1 jitsi-videobridge=1124-1 jitsi-meet-web=1.0.3577-1 jitsi-meet-web-config=1.0.3577-1 jitsi-meet-prosody=1.0.3577-1

Façam a instalação normal, seguindo o tutorial da jitsi sobre como instalar o jibri, depois executem este comando ai, que funcionará.