Problem with Ubuntu 21.10

Dears,

when I attempt to install Jitsi in my Ubuntu 21.10 system with file .deb downloaded from the official page,
I receive the error
“Dependency is not satisfiable: jitsi-archive-keyring”

someone can help me?

Best regard
Marco

This is the legacy Jitsi Desktop, right?