Problem with sockets when using self hosting server

Hi, good afternoon I followed the Self-hosting guide for installing jitsi in my ubuntu EC2 instance

If I try to access with my domain name, it works perfectly:

If I add /xmpp-websocket to the url it doesn’t throw errors
image

but if I try to use my server in my App it doesn’t work, it throws this error:

If I use the server that jitsi provides (beta.meet.jit.si) it works perfectly, any suggestion?
any feedback would be appreciated, thanks for reading!

What is your setting about it in config.js? Seems like the url is wrong trying to access your domain without the .xyz part …

Hi @damencho, you mean in the client?
I’m trying to connect to the server like this:

import JitsiMeetJS from "./jitsi";

import { groupLog } from “./loggers”;

const jitsiURI = process.env.REACT_APP_JITSI_URI;

export const getJitsiConnection = function (meetingCode) {
const connectionOptions = {
hosts: {
domain: jitsiURI,
muc: conference.${jitsiURI}, // FIXME: use XEP-0030
},
serviceUrl: wss://${jitsiURI}/xmpp-websocket?room=${meetingCode},
clientNode: https://${jitsiURI},
};
return groupLog(“Creating Jitsi Connection”, () => {
const jitsiConnection = new JitsiMeetJS.JitsiConnection(null, null, connectionOptions);
console.log(jitsiConnection);
return jitsiConnection;
});
};

and in my .env file, I have the url like this:

REACT_APP_JITSI_URI=chmontero.xyz

I already opened the ports in my ec2 instance, and I followed part of this solution to enable the websockets: [jitsi-dev] configure xmmp framework to support both websocket and BOSH

And I think that the URL is fine, but the image was a little narrowed, here’s another one of the error:

I’m not sure what am I missing, thanks for writing me back!

That is strange check nginx logs and prosody logs for errors…

Ok, I’ll take a look
one question @damencho
when it comes to bosh, the setup is less or more complex?
it’s strange, when I got the “It works! Now point your WebSocket client to this URL to connect to Prosody.” message I thought that it would be working fine

Bosh, for now, is the default choice when installing and you just need to provide the URL and that’s it.

Hi @damencho my output when I type https://chmontero.xyz/http-bind in the url is this one:

image

do you know what do I need to change in my Web Application to use Bosh instead of websockets?
I’m looking for an example but I haven’t find one

There is none at the moment, as you need to enable stream resumption and if you are not using prosody 0.11.7 you need to apply some patches.
Everything is here: https://github.com/jitsi/jitsi-meet/tree/master/resources/prosody-plugins


And add config.js like websocket: 'wss://meet.jit.si/xmpp-websocket', // FIXME: use xep-0156 for that
And make sure you have in your config: https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example#L81
And make sure you are not running ALPN multiplexing.