Problem with LDAD Authentication; stuck in connecting

Hello,
I’ve already read quite a few threads here, but just don’t find the error.
Here is an extract from the configuration files.


/etc/prosody/conf.avail/ldap.cfg.lua

– https ://modules.prosody.im/mod_lib_ldap.html
– https ://modules.prosody.im/mod_auth_ldap2.html
authentication = ‘ldap2’

ldap = {
hostname = ‘myDomain:636’,
bind_dn = ‘cn=ldap_user,ou=Lehrer,ou=Benutzer,ou=Schule,dc=domain,dc=com’,
bind_password = ‘xxxxxxxxxx’,
use_tls = true,
user = {
usernamefield = ‘sAMAccountname’,
basedn = ‘ou=Lehrer,ou=Benutzer,ou=Schule,dc=domain,dc=com’,
filter = ‘(objectClass=*)’,
– admin?
namefield = ‘cn’,
},
}


/etc/jitsi/meet/meet.example.de-config.js

/* eslint-disable no-unused-vars, no-var */

var config = {
// Connection
//

hosts: {
    // XMPP domain.
    domain: 'meet.example.de',

    // When using authentication, domain for guest users.
    anonymousdomain: 'guest.meet.example.de',

/etc/jitsi/jicofo/sip-communicator.properties

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.meet.example.de
org.jitsi.jicofo.auth.URL=XMPP:meet.example.de


/etc/prosody/prosody.cfg.lua

consider_bosh_secure = true

– Force clients to use encrypted connections? This option will
– prevent clients from authenticating unless they are using encryption.

c2s_require_encryption = true

– Force servers to use encrypted connections? This option will
– prevent servers from authenticating unless they are using encryption.

consider_bosh_secure = true

s2s_require_encryption = true

– Force certificate authentication for server-to-server connections?

s2s_secure_auth = false

– Some servers have invalid or self-signed certificates. You can list
– remote domains here that will not be required to authenticate using
– certificates. They will be authenticated using DNS instead, even
– when s2s_secure_auth is enabled.


This is my first attempt to install a Jitsi Server with LDAD authentication.

Thanks for the help
Greeting