Problem with Jwt in meet.jit.si

meet

#1

Hello,

I am trying to figure out how to use jwt properly.
Things are working great when I work with a server with authentication.
Nevertheless, I tried to use jwt with meet.jit.si for example, using ?jwt= in the url, and that has not been working quite well for me. I have a simple jwt that contains the name of the participant.
So I am trying to hit this address : https://meet.jit.si/cludy?jwt=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJjb250ZXh0Ijp7InVzZXIiOnsibmFtZSI6ImFydGh1ciJ9fX0.il2O2MLNBXr2kAZ0ajhgGWr-16QvrLv5bikhfHwZZAI

The connection to the room is fine. But there is a 500 error when calling https://meet.jit.si/http-pre-bind. The consequence is that I see “me” as my name instead of the name that I have put in the jwt. Other people in the discussion see me with the name in the jwt though.

Maybe there is something wrong with my jwt payload, could you enlight me? It is as follow
image

I have tried putting other stuff in the payload that are used for authentication like “aud”, “exp” or “room” but without success.


#2

You cannot create a valid jwt for meet.jit.si, I hope you don’t know the shared secret … :slight_smile:
You can make your own deployment, then you will know the secret you configured and can generate a valid jwt.


#3

Thanks for answering :slight_smile:

I thought that there was no secret required when the authentication part of the token was not used. Where is a password set when there is no jwt authentication?
Actually, my jwt is working well, by that I mean that other users see the name that I passed using that jwt. The part that is not working is only the http-pre-bind.