Problem with configuration new version (anonymousdomain)

Welcome. I have a problem with the administrator account after changing // anonymous domain: 'guest.my.domain,

ii  jitsi-meet                           2.0.6173-1             all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody            1.0.5211-1              all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver        1.0.5211-1              all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                  1.0.5211-1              all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config       1.0.5211-1              all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2              2.1-538-g062e9f56-1                   all          WebRTC compatible Selective Forwarding Unit (SFU)

/etc/jitsi/meet/meet.my.domain-conf.js

var config = {
    // Connection
    //

    hosts: {
        // XMPP domain.
        domain: 'meet.my.domain',

        // When using authentication, domain for guest users.
        anonymousdomain: 'guest.meet.my.domain',

        // Domain for authenticated users. Defaults to <domain>.
        // authdomain: 'meet.my.domain',

        // Focus component domain. Defaults to focus.<domain>.
        // focus: 'focus.meet.my.domian',

        // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
        muc: 'conference.<!--# echo var="subdomain" default="" -->meet.my.domain'

in

/etc/jitsi/videobridge/sip-communicator.properties

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meet.my.domain
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=oYmmBEif
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meet.my.domain
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=1fa8536c-d9e5-4eca-81d7-25a2b65a94c9
org.jitsi.jicofo.auth.URL=XMPP:meet.my.domain

/etc/prosody/conf.avail/meet.my.domain.cfg.lua

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "meet.my.domain";

external_service_secret = "JfcM60pmpfB1OEOR";
external_services = {
     { type = "stun", host = "meet.my.domain", port = 3478 },
     { type = "turn", host = "meet.my.domain", port = 3478, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "meet.my.domain", port = 5349, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
ssl = {
    protocol = "tlsv1_2+";
    ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA>
}

unlimited_jids = {
    "focus@auth.meet.my.domain",
    "jvb@auth.meet.my.domain"
}

VirtualHost "meet.my.domain"
    -- enabled = false -- Remove this line to enable this host
    authentication = "internal_hashed"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/meet.my.domain.key";
        certificate = "/etc/prosody/certs/meet.my.domain.crt";
    }
    av_moderation_component = "avmoderation.meet.my.domain"
    speakerstats_component = "speakerstats.meet.my.domain"
    conference_duration_component = "conferenceduration.meet.my.domain"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "av_moderation";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.meet.my.domain"
    main_muc = "conference.meet.my.domain"
    -- muc_lobby_whitelist = { "recorder.meet.my.domain" } -- Here we can whitelist jibri to enter lobby enabled rooms

Component "conference.meet.my.domain" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
    }
    admins = { "focus@auth.meet.my.domain" }
    muc_room_locking = false
    muc_room_default_public_jids = true
-- internal muc component
Component "internal.auth.meet.my.domain" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.meet.my.domain", "jvb@auth.meet.my.domain" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.meet.my.domain"
    ssl = {
        key = "/etc/prosody/certs/auth.meet.my.domain.key";
        certificate = "/etc/prosody/certs/auth.meet.my.domain.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.meet.my.domain" "client_proxy"
    target_address = "focus@auth.meet.my.domain"

Component "speakerstats.meet.my.domain" "speakerstats_component"
    muc_component = "conference.meet.my.domain"

Component "conferenceduration.meet.my.domain" "conference_duration_component"
    muc_component = "conference.meet.my.domain"

Component "avmoderation.meet.my.domain" "av_moderation_component"
    muc_component = "conference.meet.my.domain"

Component "lobby.meet.my.domain" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "guest.meet.my.domain"
    authentication = "anonymous"
    c2s_require_encryption = false

check the tutorial, seems you missed the Jicofo step and possibly the create user step. Learning also how to copy/paste on a forum Discouse would be good, too.

I’m sorry my Friend. Could you please paste the link to the proper documentation (Jicofo)?

But that’s not in this location

administrator@meet:~$ sudo ls -la /etc/jitsi/jicofo/
total 20
drwxr-x--- 2 jicofo jitsi 4096 Aug 24 10:48 .
drwxr-xr-x 5 root   root  4096 Aug 20 07:47 ..
-rw-r--r-- 1 jicofo jitsi  897 Aug 20 07:48 config
-rw-r--r-- 1 jicofo jitsi  351 Aug 20 07:48 jicofo.conf
-rw-r--r-- 1 jicofo jitsi 1752 Jan 22  2021 logging.properties

but there is in

administrator@meet:~$ sudo ls -la /etc/jitsi/videobridge/
total 32
drwxr-x--- 2 jvb  jitsi 4096 Aug 24 11:46 .
drwxr-xr-x 5 root root  4096 Aug 20 07:47 ..
-rw-r--r-- 1 jvb  jitsi  183 Aug  6  2019 callstats-java-sdk.properties
-rw-r--r-- 1 jvb  jitsi  827 Aug 20 07:47 config
-rw-r--r-- 1 jvb  jitsi  200 Aug 20 07:47 jvb.conf
-rw-r--r-- 1 jvb  jitsi 1068 Aug  4 23:30 log4j2.xml
-rw-r--r-- 1 jvb  jitsi 1484 Jan 23  2021 logging.properties
-rw-r--r-- 1 jvb  jitsi  697 Aug 24 10:28 sip-communicator.properties

User works fine when there is // anonymousdomain: ‘guest.my.domain’, in /etc/jitsi/meet/meet,my.domain-config.js

Thank you. It works.

Hello,

Thanks a lot for help, Looking for same issue from last couple of days but this tutorial is work for me, Really appreciate for help.

Hi Key,

Would you mind telling me how you solve the problems?
I also stuck at this step, that “Jicofo configuration”.
All tutorial I found said that add this line
“org.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com”
in the file /etc/jitsi/jicofo/sip-communicator.properties.
But this file doesn’t exist.

And the next step:
"
If you have installed Jicofo from the Debian package, this should go as a new ‘authentication’ section in /etc/jitsi/jicofo/jicofo.conf :

jicofo {
authentication: {
enabled: true
type: XMPP
login-url: jitsi-meet.example.com
}

"
This file already have some code there. So I have to add this code under the old code, or overwrite them with this one?

Thank you in advance! :blush:

There is no need to edit these files for secure domain setup. It works with default config

edited

hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.enabled true
hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.type XMPP
hocon -f /etc/jitsi/jicofo/jicofo.conf set jicofo.authentication.login-url "jitsi.yourdomain.com"

systemctl restart jicofo.service

It works!
Thank you so much!