Problem with Apache reverse proxy and jitsi meet

Hello Community :slight_smile:

Thanks for welcoming me on the forum!

I like jitsi a lot, so I’ve decided to try to install it on my home server. I use pfsense and an apache2 reverse proxy which also handles ssl using let’s encrypt. The subdomain points to my reverse proxy on port 443 (and 80), this works.

Jitsi is supposedly working on the machine. But I do have trouble getting setting up the nginx (or apache) virtual host on the jitsi-machine as well as the apache2 virtual host on the reverse proxy machine.

So I have two questions:

  • Is there a specific way I need to install jitsi? (i.e. self signed / no cert / using Let’s encrypt twice?)
  • Can anyone share a working example of these vhost-configurations?

Also, I am no informatician, as you would have guessed by now :slight_smile:

Alex

Do you have fiber with a good upload bandwitdh ? Some fiber users have about 16 Mbits/upload, that’s far too low to set a Jitsi server. If you don’t have at least reliable 50 Mbits/s upload don’t even think of having more than toy use. Even very small use (5-10 users for one meeting) need at least 100 Mbits/s.

Yes, there’s sufficient bandwith.

I use Let’sencrypt on the reverse proxy and disable https on jitsi (it’s not allowing for 100% of Jitsi-meet capabilities but it’s good enough for now). Using Let’sEncrypt twice makes no sense at all.

I see! How do you disable https on jitsi?

I use standard install that includes nginx, I edit nginx configuration and just zap everything https related :slight_smile:

1 Like

Ok :slight_smile: I am not very familiar with nginx, can you share your config? I did delete some stuff but fried the config, apparently :smiley:

Since you backed up the files before trying to change them, it does not matter.
The config change is very straightforward, the default generated config include a short http section redirecting to the larger https section immediately below, I have just deleted the last part of the first section after the ‘server_name’ line and the beginning of the second section up to and not including the root /usr/share/jitsi-meet. That’s all.

Ok, I’ll try, thanks!

It somewhat works now. No video and audio is beeing transferred as of now, but I’ll do some research before I ask questions here. thanks!

You need to NAT UDP/10000 as per this. I guess you can proxy it but I don’t know how to do that.

I just forwarded directly to the host bypassing reverse proxy. It works now :slight_smile: I will now further secure and enjoy it :smiley: