Problem to find Jibri(Jicofo and Jibri at same machine)

Hi. I’ve installed and make a call with jitsi there is no problem at this point, but when i try to record it gives “Recording unavailable” exception.
I looked through other topics about this problem but couldn’t find a solution. Please help
Here are my logsjicofo.log (32.1 KB) log.0.txt (5.4 KB) jvb.log (40.1 KB)

This is in the Jicofo logs:

reason=null]
Jicofo 2020-12-14 14:08:16.929 SEVERE: [16] org.jitsi.jicofo.xmpp.BaseBrewery.log() Failed to create room: JibriBrewery@internal.auth.meet.selin.org
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
...
Caused by: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from jibribrewery@internal.auth.meet.selin.org/focus: XMPPError: internal-server-error - wait

I’m not sure on that particular error (@damencho?), but you might try stopping prosody, jicofo and jibri and then restarting them in that same order.

Maybe something in the configuration file? @sselinkurt can you share your Jibri.conf?

Here is my jibri.conf

Thank you. I tried but there was no solution

This is where your problem is - your jibri.conf is wrong. For one, you do not have an xmpp configuration in your file (check the circled lines).

Also, the entire file seems to be missing some key config elements. Check out the sample file for how to populate that area of your jibri.conf - example_xmpp . But overall, you need to revisit the sample jibri.conf file and make sure you have every part in your jibri.conf.

You might also want to check out this topic for troubleshooting tips - TUTORIAL: Jibri Overview, Troubleshooting Tips & Tricks - Solve your Jibri Problems, Quickly!

There’s something else at play here other than missing xmpp env configs in Jibri…if Jicofo can’t join the brewery then that’s a separate problem (though what @Freddie has pointed out would also be an issue).

1 Like

Thank you for your quick reply.
I looked at the files you shared. I added these lines in environments. Is there any mistake you can see?

After adding these lines i started getting another error that “recording failed to start”.
This error occurs a few seconds after the “preparing to record”.
So I checked every step in the title “Recording fails after a few seconds” in your tutorial. I still get the same error.

I already copied the jibri.conf file you shared. Is there anything I need to add to the jibri.conf other than xmpp lines?

Can you just upload the full jibri.conf file instead of screenshots? I’m uncertain whether you have the full configuration with these snippets. One thing I see that’s missing from this though:

strip-from-room-domain = “conference.”

sure jibri.txt (4.5 KB)

You have a missing dot

I added this line. It is visible in the jibri.txt file above. Unfortunately no solution

It’s not exist in the shared file. There should be a dot after the word conference

sorry, my mistake :frowning:
I added dot and restarted the services. Still getting the same error…

According to your initial logs, the issue is related in the prosody side. Do you get the same error in the logs or do you mean the “recording unavailable” message?

I mean “recording unavailable” message.

Can you share your latest jicofo and jibri logs?

@Freddie jicofo.log (593.2 KB) log.0.txt (6.5 KB) jvb.log (934.2 KB)

Just curious: what java version do you have?

I’m using /usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java
openjdk version “1.8.0_275”