Problem Screensharing - no picture with more like two users

Hello Folks,

at the weekend we upgraded our project nerd.re to the current Jitis version. Everything works wonderfully except for the screen sharing. As soon as more than two people enter the conference, the screenshare is gone and only the gray background remains.

Tested with the current Chrome version 97 and Jitsi Version:
rc jitsi-meet 2.0.6726-1
ii jitsi-meet-prosody 1.0.5675-1
ii jitsi-meet-web 1.0.5675-1
ii jitsi-meet-web-config 1.0.5675-1
rc jitsi-videobridge2 2.1-595-g3637fda4-1

Link to our Jitsis https://meet.nerd.re/

THX as0bit

rc” means the package is not installed

Thanks for the information.
I had forgotten to write that we have the jvb on separate hardware
meet.nerd.re
jvb1.meet.nerd.re
jvb3.meet.nerd.re
jvb4.meet.nerd.re

jitsi-meet also seems to be removed.

Probably you have websocket issue too. Did you check browser console logs?

I suspect that jitsi-meet on rc is because the jvb is uninstalled. Otherwise it wouldn’t work?

In the browser console I only see the following messages. However, these are independent of screen sharing. And as I said, the conference, even with a large number of participants, ran without any problems

Logger.js: 154 2022-01-05T14: 55: 43.740Z [JitsiConference.js] <Qa.sendMessage>: Failed to send E2E ping request or response. undefined

Logger.js: 154 2022-01-05T14: 56: 03.712Z [modules / RTC / BridgeChannel.js] <Kr._send>: Bridge Channel send: no opened channel.

This means that there is a websocket issue.

Don’t uninstall JVB. Disable it using

systemctl stop jitsi-videobridge2.service
systemctl disable jitsi-videobridge2.service

corrected that, thanks for the tip

Do you have a suggestion how I can best solve the problem. Or where should I look?

1 Like

That was the solution, thank you very much :star_struck:. But the description there really made us think a little bit because we didn’t understand it directly.

  • Add the following location block to Nginx site config on JMS. This block must be right after the default JVB1’s colibri location block.
    # colibri (JVB) websockets for additional JVBs
    location ~ ^/colibri-ws/([0-9.]*)/(.*) {
        proxy_pass http://$1:9090/colibri-ws/$1/$2$is_args$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        tcp_nodelay on;
    }

is absolutely correct but the local jvb1 on the JMS has to be commented out in the nginx config because I have disabled the local jvb.

here we had our understanding problems

  • Set JVBs’ own public IP as server-id for each additional JVBs. server-id must be in the websockets block of the /etc/jitsi/videobridge/jvb.conf file for each additional JVB (but not for the main JVB which is located on JMS)

On every additinal jvb the own external JVB ip-address must be in the jvb.conf as well as that of the JMS server.

here is our example of the configuration on jvb4 (jvb4.meet.nerd.re = 202.61.243.193 | meet.nerd.re = JMS)

 websockets {
        server-id = "202.61.243.193" 
        enabled = true
        domain = "meet.nerd.re:443"
        tls = true

    }

(actually the FQDN from the JVB should also work, but I haven’t tried that yet)

many thanks for the quick help
greeting

as0bit