Problem in starting jitsi-videobridge.


#1

Hello Developers,

I have just started using jitsi, and I was trying to install and configure Jitsi-Meet on ubuntu 16.04 using

the instructions at https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md

But I keep getting an error while trying to start the videobridge using

the following command.

./jvb.sh --host=localhost --domain=localhost --port=5347 --secret=

YOURSECRET1 &

However, I do always get the following error again and again:

#starting error

JVB 2018-10-10 20:50:00.620 INFO: [1] util.NetworkUtils.().117 java.net.preferIPv6Addresses=null

JVB 2018-10-10 20:50:00.624 INFO: [1] util.NetworkUtils.().118 java.net.preferIPv4Stack=null

SLF4J: Class path contains multiple SLF4J bindings.

At the end of terminal output it always shows this and it repeats:

JVB 2018-10-10 21:19:34.577 FINE: [94] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId hO327-6):

JVB 2018-10-10 21:19:34.578 FINE: [94] org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV:

JVB 2018-10-10 21:19:34.597 INFO: [15] org.jitsi.videobridge.Videobridge.log() CAT=stat create_conf,conf_id=b8dba34427390a7a conf_name=null,logging=false,conf_count=1,ch_count=0,v_streams=0

JVB 2018-10-10 21:19:34.754 INFO: [15] org.jitsi.videobridge.health.Health.log() Performed a successful health check in 158ms. Sticky failure: false

JVB 2018-10-10 21:19:39.251 FINE: [155] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId sqevq-490):

JVB 2018-10-10 21:19:39.252 FINE: [155] org.jitsi.videobridge.xmpp.ComponentImpl.processIQRequest() (serving component ‘JitsiVideobridge’) Processing IQ request (packetId sqevq-490).

when i restart prosody with the following command.

sudo prosodyctl restart

It says, prosody is already running with PID ****

Also in /etc/init.d/ i am unable to find jitsi-videobridge but i have prosody in it( /etc/init.d/prosody).

Mentioning this, in case it has to do something with this.

Also, when i start jicofo it shows this in the prosody log file.

#prosody log after starting jicogo

Oct 10 21:05:08 focus.jitsi.example.com:component info External component successfully authenticated

Oct 10 21:05:09 c2s14105c0 info Authenticated as focus@auth.jitsi.example.com

Oct 10 21:05:09 jitsi-videobridge.jitsi.example.com:component warn Component not connected, bouncing error for:

#Terminal output after starting jicofo

Jicofo 2018-10-10 21:05:09.227 INFO: [25] org.jitsi.jicofo.ComponentsDiscovery.scheduleRediscovery().189 Services re-discovery interval: 30000

Jicofo 2018-10-10 21:05:09.234 INFO: [25] org.jitsi.jicofo.FocusManager.log() XMPP provider reg state: RegistrationState=Registered

Jicofo 2018-10-10 21:05:09.253 INFO: [25] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 XMPP provider Jabber:focus@auth.jitsi.example.com/focus34210837568472@localhost connected (JID: focus@auth.jitsi.example.com/focus34210837568472)

Jicofo 2018-10-10 21:19:39.361 INFO: [41] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().267 New component discovered: jitsi-videobridge.jitsi.example.com, IQ Stanza (query jabber:iq:version) [to=focus@auth.jitsi.example.com/focus34210837568472,from=jitsi-videobridge.jitsi.example.com,id=sqevq-492,type=result,]

Jicofo 2018-10-10 21:19:39.361 INFO: [41] org.jitsi.jicofo.BridgeSelector.addJvbAddress().215 Added videobridge: jitsi-videobridge.jitsi.example.com v: IQ Stanza (query jabber:iq:version) [to=focus@auth.jitsi.example.com/focus34210837568472,from=jitsi-videobridge.jitsi.example.com,id=sqevq-492,type=result,]

Jicofo 2018-10-10 21:19:39.361 WARNING: [41] org.jitsi.jicofo.BridgeSelector.addJvbAddress().227 No pub-sub node mapped for jitsi-videobridge.jitsi.example.com

Jicofo 2018-10-10 21:19:39.373 INFO: [85] org.jitsi.jicofo.JvbDoctor.log() Scheduled health-check task for: jitsi-videobridge.jitsi.example.com

Jicofo 2018-10-10 21:24:59.374 WARNING: [91] org.jitsi.jicofo.JvbDoctor.log() Health check failed on: jitsi-videobridge.jitsi.example.com error: Component unavailable

Jicofo 2018-10-10 21:24:59.375 INFO: [85] org.jitsi.jicofo.BridgeSelector.removeJvbAddress().261 Removing JVB: jitsi-videobridge.jitsi.example.com

Jicofo 2018-10-10 21:24:59.378 INFO: [85] org.jitsi.jicofo.JvbDoctor.log() Stopping health-check task for: jitsi-videobridge.jitsi.example.com

Jicofo 2018-10-10 21:25:09.261 INFO: [41] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().299 Component went offline: jitsi-videobridge.jitsi.example.com

I have also referred https://github.com/jitsi/jitsi-videobridge/issues/334 and I have been trying to figure out the problem and haven’t had any luck with it. Please let me know what changes should I do. And in which files ?

I hope for a positive response soon.

Thanks.


#2

So your jicofo and deployment are jitsi.example.com where your jvb is using domain localhost, this doesn’t look right.

Why are you using the manual install steps, instead of the quick install one? The manual install you will face many problems which are already solved by the debian install scripts.


#3

Hello sir, I have also tried quick install step by step from this video.[https://youtu.be/8KR0AhDZF2A]. I am setting jitsi video bridge on Ubuntu 16.04.

By quick install, I am facing this problem after running this command:

sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Cleaning up challenges
Failed authorization procedure. jitsi.example.com (http-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up A for jitsi.example.com

IMPORTANT NOTES:


#4

In order to use let’s encrypt certificates your domain needs to have a valid dns entry.


#5

Can you elaborate it please ? Like how can I have a valid Dns entry ?


#6

You need to go and buy a domain and configure in its provider’s console the A record to point to your public ipv4 address where you are hosting your deployment.