Problem in jibri recording

please help me to resolve jibri issue

Jibri Logs

2021-04-09 11:42:04.772 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2021-04-09 11:42:04.908 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Checking legacy config file /etc/jitsi/jibri/config.json
2021-04-09 11:42:04.908 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Legacy config file /etc/jitsi/jibri/config.json doesn’t exist
2021-04-09 11:42:05.900 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() got jwtConfig: {}

2021-04-09 11:42:05.901 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 79: No configuration setting found for key ‘signing-key-path’
2021-04-09 11:42:06.086 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2021-04-09 11:42:06.097 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-04-09 11:42:06.470 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2021-04-09 11:42:06.479 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on localhost with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[localhost], xmppDomain=meet.mashvirtual.info, controlLogin=XmppCredentials(domain=auth.meet.mashvirtual.info, username=jibri, password=P12345), controlMuc=XmppMuc(domain=internal.meet.mashvirtual.info, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.meet.mashvirtual.info, username=recorder, password=P12345), stripFromRoomDomain=conference.meet.mashvirtual.info, usageTimeoutMins=0, trustAllXmppCerts=true)
2021-04-09 11:42:06.480 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2021-04-09 11:42:06.506 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for HTTP API
2021-04-09 11:42:06.507 WARNING: [27] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2021-04-09 11:42:06.736 INFO: [27] org.jitsi.xmpp.mucclient.MucClient.log() Connected.
2021-04-09 11:42:06.737 INFO: [27] org.jitsi.xmpp.mucclient.MucClient.log() Logging in.
2021-04-09 11:42:07.295 SEVERE: [27] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionAuthenticatedListener() Exception in authenticated listener
java.lang.RuntimeException: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.meet.mashvirtual.info: XMPPError: remote-server-not-found - cancel
at org.jitsi.xmpp.mucclient.MucClient$1.authenticated(MucClient.java:287)
at org.jivesoftware.smack.AbstractXMPPConnection.callConnectionAuthenticatedListener(AbstractXMPPConnection.java:1297)
at org.jivesoftware.smack.AbstractXMPPConnection.afterSuccessfulLogin(AbstractXMPPConnection.java:572)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.afterSuccessfulLogin(XMPPTCPConnection.java:379)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.loginInternal(XMPPTCPConnection.java:444)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:491)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:448)
at org.jitsi.xmpp.mucclient.MucClient.lambda$getConnectAndLoginCallable$7(MucClient.java:681)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.meet.mashvirtual.info: XMPPError: remote-server-not-found - cancel
at org.jivesoftware.smack.XMPPException$XMPPErrorException.ifHasErrorThenThrow(XMPPException.java:132)
at org.jivesoftware.smack.StanzaCollector.nextResultOrThrow(StanzaCollector.java:263)
at org.jivesoftware.smack.StanzaCollector.nextResultOrThrow(StanzaCollector.java:214)
at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryManager.java:540)
at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryManager.java:506)
at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.supportsFeatures(ServiceDiscoveryManager.java:748)
at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.supportsFeatures(ServiceDiscoveryManager.java:744)
at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.supportsFeature(ServiceDiscoveryManager.java:740)
at org.jivesoftware.smackx.muc.MultiUserChatManager.providesMucService(MultiUserChatManager.java:361)
at org.jivesoftware.smackx.muc.MultiUserChat.enter(MultiUserChat.java:311)
at org.jivesoftware.smackx.muc.MultiUserChat.createOrJoin(MultiUserChat.java:498)
at org.jivesoftware.smackx.muc.MultiUserChat.createOrJoin(MultiUserChat.java:444)
at org.jitsi.xmpp.mucclient.MucClient$MucWrapper.join(MucClient.java:769)
at org.jitsi.xmpp.mucclient.MucClient$MucWrapper.access$700(MucClient.java:698)
at org.jitsi.xmpp.mucclient.MucClient.joinMucs(MucClient.java:389)
at org.jitsi.xmpp.mucclient.MucClient.access$200(MucClient.java:50)
at org.jitsi.xmpp.mucclient.MucClient$1.authenticated(MucClient.java:283)
… 15 more
2021-04-09 11:43:06.080 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status

Looks like your config is wrong. Post your jibri.conf.

jibri {
// A unique identifier for this Jibri
// TODO: eventually this will be required with no default
id = “”
// Whether or not Jibri should return to idle state after handling
// (successfully or unsuccessfully) a request. A value of ‘true’
// here means that a Jibri will NOT return back to the IDLE state
// and will need to be restarted in order to be used again.
single-use-mode = false
api {
http {
external-api-port = 2222
internal-api-port = 3333
}
xmpp {
// See example_xmpp_envs.conf for an example of what is expected here
environments = [
{
name = “prod environment”
xmpp-server-hosts = [“localhost”]
xmpp-domain = “meet.mashvirtual.info”

            control-muc {
                domain = "internal.meet.mashvirtual.info"
                room-name = "JibriBrewery"
                nickname = "jibri-nickname"
            }

            control-login {
                domain = "auth.meet.mashvirtual.info"
                username = "jibri"
                password = "Pass12345"
            }

            call-login {
                domain = "recorder.meet.mashvirtual.info"
                username = "recorder"
                password = "Pass12345"
            }

            strip-from-room-domain = "conference.meet.mashvirtual.info"
            usage-timeout = 0
            trust-all-xmpp-certs = true
        }]
}

}
recording {
recordings-directory = “/srv/recordings”
# TODO: make this an optional param and remove the default
finalize-script = “/path/to/finalize”
}
streaming {
// A list of regex patterns for allowed RTMP URLs. The RTMP URL used
// when starting a stream must match at least one of the patterns in
// this list.
rtmp-allow-list = [
// By default, all services are allowed
“.*”
]
}
chrome {
// The flags which will be passed to chromium when launching
flags = [
“–use-fake-ui-for-media-stream”,
“–start-maximized”,
“–kiosk”,
“–enabled”,
“–disable-infobars”,
“–autoplay-policy=no-user-gesture-required”
]
}
stats {
enable-stats-d = true
}
webhook {
// A list of subscribers interested in receiving webhook events
subscribers =
}
jwt-info {
// The path to a .pem file which will be used to sign JWT tokens used in webhook
// requests. If not set, no JWT will be added to webhook requests.
# signing-key-path = “/path/to/key.pem”

// The kid to use as part of the JWT
# kid = "key-id"

// The issuer of the JWT
# issuer = "issuer"

// The audience of the JWT
# audience = "audience"

// The TTL of each generated JWT.  Can't be less than 10 minutes.
# ttl = 1 hour

}
call-status-checks {
// If all clients have their audio and video muted and if Jibri does not
// detect any data stream (audio or video) comming in, it will stop
// recording after NO_MEDIA_TIMEOUT expires.
no-media-timeout = 30 seconds

// If all clients have their audio and video muted, Jibri consideres this
// as an empty call and stops the recording after ALL_MUTED_TIMEOUT expires.
all-muted-timeout = 10 minutes

// When detecting if a call is empty, Jibri takes into consideration for how
// long the call has been empty already. If it has been empty for more than
// DEFAULT_CALL_EMPTY_TIMEOUT, it will consider it empty and stop the recording.
default-call-empty-timeout = 30 seconds

}
}

That needs to be your domain, not localhost.

Needs to be “internal.auth.meet.mashvirtual.info”

Needs to be just “conference.”

Sir, Kindly guide me what is my final config

● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-04-09 13:36:19 IST; 2s ago
Process: 20003 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Main PID: 20007 (java)
Tasks: 36 (limit: 4596)
CGroup: /system.slice/jibri.service
└─20007 /usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -Dconfig.file=/etc/jitsi/jibri/jibri.conf

Apr 09 13:36:22 devserver launch.sh[20007]: Exception in thread “main” org.jitsi.metaconfig.ConfigException$UnableToRetrieve$NotFound: No suppliers found a value:
Apr 09 13:36:22 devserver launch.sh[20007]: org.jitsi.metaconfig.ConfigException$UnableToRetrieve$NotFound: Considering empty XMPP envs list as not found
Apr 09 13:36:22 devserver launch.sh[20007]: org.jitsi.metaconfig.ConfigException$UnableToRetrieve$Error: /etc/jitsi/jibri/jibri.conf: 18: No configuration setting found for key ’
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.metaconfig.supplier.FallbackSupplier.doGet(FallbackSupplier.kt:57)
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.metaconfig.supplier.ConfigValueSupplier$value$2.invoke(ConfigValueSupplier.kt:30)
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.metaconfig.supplier.ConfigValueSupplier$value$2.invoke(ConfigValueSupplier.kt:29)
Apr 09 13:36:22 devserver launch.sh[20007]: at kotlin.SynchronizedLazyImpl.getValue(LazyJVM.kt:74)
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.metaconfig.supplier.ConfigValueSupplier.getValue(ConfigValueSupplier.kt)
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.metaconfig.supplier.ConfigValueSupplier.get(ConfigValueSupplier.kt:32)
Apr 09 13:36:22 devserver launch.sh[20007]: at org.jitsi.jibri.MainKt.main(Main.kt:142)

That needs to be just:

strip-from-room-domain = "conference."

Read through this post, it will help you resolve your issues - TUTORIAL: Jibri Overview, Troubleshooting Tips & Tricks - Solve your Jibri Problems, Quickly!

Dear Sir,
jibri service not started

jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-04-09 14:55:20 IST; 3min 17s ago
Process: 6267 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Process: 6246 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 6246 (code=exited, status=143)

Apr 09 14:55:20 devserver graceful_shutdown.sh[6267]: % Total % Received % Xferd Average Speed Time Time Time Current
Apr 09 14:55:20 devserver graceful_shutdown.sh[6267]: Dload Upload Total Spent Left Speed
Apr 09 14:55:20 devserver graceful_shutdown.sh[6267]: [149B blob data]
Apr 09 14:55:20 devserver systemd[1]: jibri.service: Control process exited, code=exited status=7
Apr 09 14:55:20 devserver systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Apr 09 14:55:20 devserver systemd[1]: jibri.service: Failed with result ‘exit-code’.
Apr 09 14:55:20 devserver systemd[1]: Stopped Jibri Process.
Apr 09 14:55:20 devserver systemd[1]: jibri.service: Start request repeated too quickly.
Apr 09 14:55:20 devserver systemd[1]: jibri.service: Failed with result ‘exit-code’.
Apr 09 14:55:20 devserver systemd[1]: Failed to start Jibri Process.

Did you go through that link and tried rechecking if all configuration is as expected?

yes i have check all setting as per provided link

jitsi-jibri-installer

2021-04-10 11:20:46 (23.8 MB/s) - ‘/tmp/jbi-custom-input’ saved [1152/1152]

–2021-04-10 11:20:46-- https://raw.githubusercontent.com/emrahcom/emrah-tools/main/jitsi/installer/jibri//jbi-custom-extra
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 185.199.111.133, 185.199.110.133, 185.199.109.133, …
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.111.133|:443… connected.
HTTP request sent, awaiting response… 301 Moved Permanently
Location: /emrahcom/emrah-tools/main/jitsi/installer/jibri/jbi-custom-extra [following]
–2021-04-10 11:20:46-- https://raw.githubusercontent.com/emrahcom/emrah-tools/main/jitsi/installer/jibri/jbi-custom-extra
Reusing existing connection to raw.githubusercontent.com:443.
HTTP request sent, awaiting response… 200 OK
Length: 6002 (5.9K) [text/plain]
Saving to: ‘/tmp/jbi-custom-extra’

/tmp/jbi-custom-ext 100%[===================>] 5.86K --.-KB/s in 0s

2021-04-10 11:20:47 (19.6 MB/s) - ‘/tmp/jbi-custom-extra’ saved [6002/6002]

This script can be harmful and will remove already installed Jitsi if exists.
Don’t use it on a working production server.
Write YES (uppercase) and press enter if you are crazy!
YES

checking the user account…

checking the distro…

Aborted! Your distro is not supported
Recommendation: Switch to Debian 10 Buster or Ubuntu 20.04 Focal Fossa

Something went wrong. Not completed!
root@devserver:~#

Kindly help to resolve below jibri log

2021-04-10 12:22:19.479 INFO: [111] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq() Received JibriIq from environment [MucClient id=localhost hostname=localhost]
2021-04-10 12:22:19.480 INFO: [111] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Received start request, starting service
2021-04-10 12:22:19.480 SEVERE: [111] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Error starting Jibri service : org.jitsi.jibri.util.CallUrlInfoFromJidException: Unable to extract call url info from Jid kk@conference.meet.mashvirtual.info (stripFromRoomDomain = conference.meet.mashvirtual.info, xmppDomain = meet.mashvirtual.info) with stack:
org.jitsi.jibri.util.XmppUtilsKt.getCallUrlInfoFromJid(XmppUtils.kt:47)
org.jitsi.jibri.api.xmpp.XmppApi.handleStartService(XmppApi.kt:280)
org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq(XmppApi.kt:195)
org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq(XmppApi.kt:168)
org.jitsi.jibri.api.xmpp.XmppApi.handleIq(XmppApi.kt:150)
org.jitsi.xmpp.mucclient.MucClient.handleIq(MucClient.java:569)
org.jitsi.xmpp.mucclient.MucClient.access$800(MucClient.java:50)
org.jitsi.xmpp.mucclient.MucClient$2.handleIQRequest(MucClient.java:533)
org.jivesoftware.smack.AbstractXMPPConnection$4.run(AbstractXMPPConnection.java:1188)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

2021-04-10 12:22:45.363 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status

What operating system are you using? Your previous comment, where you tried to install with script says, installation was not complete. Was that the case?

Ubuntu 18.4 jitsi meet already working in this server with auth

for jibri followed below steps

If you have followed those steps, it should work. May be you had missed something.

Are you willing to reinstall everything from scratch?

recording failed to start

jibri log log.0.txt (133.5 KB)

  1. What is the configuration of the server?

Also this post is marked with a solution. So you may not get any responses.

Why was it marked as a solution, when your log clearly shows jibri installation did not succeed?

Sorry by mistake check on solution
Xenon Metal server with 8 GB Ram and 1 TB Storage , Ubuntu 18.4

Jitsi Meet already working form past 6 month now need jibri

kindly help me to setup jibri in jitsi Meet same server

Config looks good. Are you using self signed certs or letsencrypt?