Problem during installation on Ubuntu server 16.04

Good evening, I have configured the server with ssh, apache2 and bind9. Until this point everything is ok.
When I ran the following command
“/Usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh”
the following errors appeared: "


This script will:

  • Need a working DNS record pointing to this machine (for domain meet.cspjitsi.it)
  • Download certbot-auto from …dl.eff.org to / usr / local / sbin
  • Install additional dependencies in order to request Let’s Encrypt certificate
  • If running with jetty serving web content, it will stop Jitsi Videobridge
  • Configure and reload nginx or apache2, whichever is used

You need to agree to the ACME server’s Subscriber Agreement (…letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf)
by providing an email address for important account notifications
Enter your email and press [ENTER]: Bootstrapping dependencies for Debian-based OSes … (you can skip this with --no-bootstrap)
Found: 1 …en.archive.ubuntu.com/ubuntu xenial InRelease
Download of: 2 …en.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Download of: 3 …en.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Download of: 4 …security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Found: 5 …download.jitsi.org stable / InRelease
325 kB recovered in 0s (359 kB / s)
Reading package list …
Reading package list …
Dependency tree generation …
Reading status information …
gcc is already the newest version (4: 5.3.1-1ubuntu1).
libffi-dev is already the newest version (3.2.1-4).
augeas-lenses is already the newest version (1.4.0-0ubuntu1.1).
ca-certificates is already the newest version (20170717 ~ 16.04.2).
libaugeas0 is already the newest version (1.4.0-0ubuntu1.1).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.15).
openssl is already the newest version (1.0.2g-1ubuntu4.15).
python is already the newest version (2.7.12-1 ~ 16.04).
python-dev is already the newest version (2.7.12-1 ~ 16.04).
python-virtualenv is already the newest version (15.0.1 + ds-3ubuntu1).
virtualenv is already the newest version (15.0.1 + ds-3ubuntu1).
0 updated, 0 installed, 0 to be removed and 118 not updated.
Creating virtual environment …
Installing Python packages …
File “/tmp/tmp.tfG7UH1wRf/pipstrap.py”, line 177, in
sys.exit (main ())
File “/tmp/tmp.tfG7UH1wRf/pipstrap.py”, line 158, in main
for path, digest in PACKAGES]
File “/tmp/tmp.tfG7UH1wRf/pipstrap.py”, line 121, in hashed_download
for chunk in read_chunks (response, 4096):
File “/tmp/tmp.tfG7UH1wRf/pipstrap.py”, line 111, in read_chunks
chunk = response.read (chunk_size)
File “/usr/lib/python2.7/socket.py”, line 384, in read
data = self._sock.recv (left)
File “/usr/lib/python2.7/httplib.py”, line 622, in read
s = self.fp.read (amt)
File “/usr/lib/python2.7/socket.py”, line 384, in read
data = self._sock.recv (left)
File “/usr/lib/python2.7/ssl.py”, line 756, in recv
return self.read (buflen)
File “/usr/lib/python2.7/ssl.py”, line 643, in read
v = self._sslobj.read (len)
socket.error: [Errno 104] Connection reset by peer
"
I can’t understand who caused this error.
Can you help me?
Thank you.

Did you enter email address at this step and then hit Enter?

salvatcm@gmail.com

Hi,

I have exactly the same error, its being caused by certbot-auto

I have not found a workaround yet, I have followed guides at

Fresh install of fresh Ubuntu 16.04.4 LTS

I have ran the same install on Debian and have exactly the same issue.
Debian 4.19.98-1.

Could you try the following?

echo "<your-email>" | /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh