Private Interface API return 503

I am following this guide to enable the API

I add modified the java parameter:

extra options to pass to the JVB daemon

JVB_OPTS="–apis=rest,xmpp"

then test the api from jitsi server using curl:

curl -v http://localhost:8080/colibri/stats

  • Trying ::1:8080…
  • TCP_NODELAY set
  • Connected to localhost (::1) port 8080 (#0)

GET /colibri/stats HTTP/1.1
Host: localhost:8080
User-Agent: curl/7.65.2
Accept: /

  • Mark bundle as not supporting multiuse
    < HTTP/1.1 503 Service Unavailable
    < Date: Thu, 26 Dec 2019 08:38:00 GMT
    < Content-Type: application/json;charset=utf-8
    < Access-Control-Allow-Origin: *
    < Content-Length: 0
    < Server: Jetty(9.4.15.v20190215)
    <
  • Connection #0 to host localhost left intact

it return 503 error.

I see some errors in the jvb log.
JVB 2019-12-26 08:25:10.641 INFO: [10] org.eclipse.jetty.server.AbstractConnector.doStart() Started MuxServerConnector@4d7acfe4{HTTP/1.1,[http/1.1]}{0.0.0.0:8080}
JVB 2019-12-26 08:25:10.641 INFO: [10] org.eclipse.jetty.server.Server.doStart() Started @516ms
JVB 2019-12-26 08:25:10.645 INFO: [10] org.jitsi.rest.AbstractJettyBundleActivator.start().613 Not starting the Jetty service for org.jitsi.videobridge.rest.PublicRESTBundleActivator(port=-1)
JVB 2019-12-26 08:25:10.645 INFO: [10] org.jitsi.rest.AbstractJettyBundleActivator.start().613 Not starting the Jetty service for org.jitsi.videobridge.rest.PublicClearPortRedirectBundleActivator(port=8080)

is there any other steps need to do ?

Make sure stats are enabled.

Thanks. it works now.

I am learning the Colibri API now. I want to translate the colibri to SDP. is there any code in jitsi web I can learn ?