Prevent docker from overwriting confiurations

I’m trying to set up octo and multiple jvbs using docker and for that I change values e.g. in ~/.jitsi-meet-cfg/jvb/sip-communicator.properties but every time the container starts, that file gets overwritten…

How do I stop that from happening? I already tried to make the config readonly but then the jvb container just stops because of it…

With the other configurations, it is also the case that they cannot be changed directly. They must be written in .env and in docker-compose.yaml.
docker-compose.yaml:
version: ‘3’
services:
web:
environment:

  • ENABLE_AUTH
  • ENABLE_GUESTS

.env:
ENABLE_AUTH=1
ENABLE_GUESTS=0

Here is a list of possible variables:

Thanks, but those are just the options for the config.js but I’m trying to modify the jvb/sip-communicator.properties.

(a workaround for config.js is to use a backup file and just periodically overwrite the used config.js as that one should be read with each new request. But I don’t think the same is true for the sip-communicator.properties. Those afaik only get loaded at the start, therefore any change during runtime is irrelevant).

did you create your own docker image @kevinkk525?

FYI: All the config from sip-communicator.properties is moving to new file jvb.conf. check the master branch.

I’m not using my own docker image, I just follow the official instructions.
However, for configuring many things the instructions are not for the docker version so I have to manually modify files and if those configs moved in docker, that’s not reflected in (old) instructions for (mainly) non-docker installations.

Thanks for the hint about the jvb.conf, I’ll take a look.