"Preparing to Record Meeting" to "Recording failed"

I installed and configured everything propery, jitsi-meet is working absolutely fine.
Problem rose when I decided to setup jibri to record all my meetings. For this I configuerd jibri in a VMware, according the official video on youtube from Jitsi.
Everything worked fine, all services, jibri, xorg. etc are in active mode in my ubuntu server version in VM, yet still when I click on “Start meeting” option, a pop-up comes saying"Preparing to start meeting" and then suddenly after two seconds, antoher popup in red appears says "Recording failed’ .
Will you please help me troubleshooting this issue. I have to get it done on urgent basis, I am already running late.
Here are my jibri logs:





Try running jibri with java8

I tried it with java 8 but still facing the same. It first says, Preparing to record meeting, then it says Recording stopped and then Recording unavailable.:frowning_face:

  • Double check the Java version

  • Reserv at least 4 CPU and 4 GB RAM for jibri

Yes I have 4GB of RAM and 4 CPU cores reserved for jibri.

  • check the snd_aloop module
modprobe snd-aloop
lsmod | grep aloop
  • There should be no running desktop environment on the jibri server. If you installed the desktop packages, reinstall the server without them.

  • Check log on /var/log/jitsi/jibri

Thank you @emrah.
Module is loaded, there is no issue with that. There is no desktop environment running, just command line server and nothing else.
And I have posted the logs above, can you please have a look at them.

These are the old logs which point a Java version problem. These are not helpful for the current situation.