PreDepends: jitsi-videobridge2 (= 2.1-174-g1cd8ec59-1) but 2.1-272-g4390f610-1 is installed

I just tried to do an apt update and am seeing the following now…

jitsi-meet : PreDepends: jitsi-videobridge2 (= 2.1-174-g1cd8ec59-1) but 2.1-272-g4390f610-1 is installed

Notice it says it wants 2.1-174 in the error but when I run the command below it tries to install 2.1-274-g9bbf2713-1

Somehow I managed to get a version newer than the latest version? I am pointing at unstable. It told me to run apt --fix-broken install but when I did I got this…

brimur# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  coturn jitsi-meet-turnserver libevent-core-2.1-6 libevent-extra-2.1-6 libevent-openssl-2.1-6 libevent-pthreads-2.1-6 libhiredis0.13 libmysqlclient20 libpq5 mysql-common
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
Recommended packages:
  jitsi-meet-turnserver | apache2
The following packages will be upgraded:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
6 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
7 not fully installed or removed.
Need to get 51.2 MB/102 MB of archives.
After this operation, 41.3 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 https://download.jitsi.org unstable/ jitsi-videobridge2 2.1-274-g9bbf2713-1 [44.2 MB]
Get:2 https://download.jitsi.org unstable/ jitsi-meet 2.0.4866-1 [2,864 B]
Get:3 https://download.jitsi.org unstable/ jitsi-meet-web 1.0.4297-1 [6,936 kB]
Get:4 https://download.jitsi.org unstable/ jitsi-meet-web-config 1.0.4297-1 [14.8 kB]
Get:5 https://download.jitsi.org unstable/ jitsi-meet-prosody 1.0.4297-1 [39.1 kB]
Fetched 51.2 MB in 6s (8,885 kB/s)
Preconfiguring packages ...
(Reading database ... 108396 files and directories currently installed.)
Preparing to unpack .../jitsi-videobridge2_2.1-274-g9bbf2713-1_all.deb ...
Unpacking jitsi-videobridge2 (2.1-274-g9bbf2713-1) over (2.1-272-g4390f610-1) ...
Setting up jitsi-videobridge2 (2.1-274-g9bbf2713-1) ...
/etc/jitsi/videobridge/config: line 23: net.core.rmem_max=10485760: command not found
dpkg: error processing package jitsi-videobridge2 (--configure):
 installed jitsi-videobridge2 package post-installation script subprocess returned error exit status 127
E: Sub-process /usr/bin/dpkg returned an error code (1)

I havent touched my config files since they were setup so Im not sure whats going on here espcially with the “command not found” on the rmem.

Could you paste the output?

uname -a
cat /etc/os-release
ls /etc/sysctl.d/ -alh
brimur@meet:~$ uname -a
Linux meet 4.15.0-109-generic #110-Ubuntu SMP Tue Jun 23 02:39:32 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
brimur@meet:~$ cat /etc/os-release
NAME="Ubuntu"
VERSION="18.04.4 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.4 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic
brimur@meet:~$ ls /etc/sysctl.d/ -alh
total 52K
drwxr-xr-x   2 root root 4.0K Jul 14 15:17 .
drwxr-xr-x 101 root root 4.0K Jul 14 16:19 ..
-rw-r--r--   1 root root   77 Jan 17  2018 10-console-messages.conf
-rw-r--r--   1 root root  135 Apr 10 16:53 10-ipv6-privacy.conf
-rw-r--r--   1 root root  726 Jan 17  2018 10-kernel-hardening.conf
-rw-r--r--   1 root root  257 Jan 17  2018 10-link-restrictions.conf
-rw-r--r--   1 root root  153 Jun  5  2018 10-lxd-inotify.conf
-rw-r--r--   1 root root 1.2K Jan 17  2018 10-magic-sysrq.conf
-rw-r--r--   1 root root  509 Jan 17  2018 10-network-security.conf
-rw-r--r--   1 root root 1.3K Jan 17  2018 10-ptrace.conf
-rw-r--r--   1 root root  506 Jan 17  2018 10-zeropage.conf
-rw-r--r--   1 root root  140 Aug  6  2019 20-jvb-udp-buffers.conf
lrwxrwxrwx   1 root root   14 May  3 11:30 99-sysctl.conf -> ../sysctl.conf
-rw-r--r--   1 root root  519 Jan 17  2018 README

I’m suspecting that your distro/kernel has a problem with net.core.rmem_max. Could you test the following command too as root

sysctl -p /etc/sysctl.d/20-jvb-udp-buffers.conf

Thanks @emrah
I tried that and it just outputted the values in the config file.
So I tried commenting out net.core.rmem_max=10485760 and running apt --fix-broken install and got the same error with the next line net.core.netdev_max_backlog=100000 so I commented them both and ran apt --fix-broken install a third time and this time it completed and I was able to do an apt update && apt upgrade and they both completed. I then uncommented the two lines in the config file.

Can I confirm that the two lines should be this?..

this sets the max, so that we can bump the JVB UDP single port buffer size.
net.core.rmem_max=10485760
net.core.netdev_max_backlog=100000

Is that dedicating 1GB of RAM to UDP buffering?

Looks like I have a new issue now…

I cant get past this screen. Asking me to allow even though I have already done so. Luckily my meet server is a VM and I can restore to a snapshot I took before the update so I can get it working again but wanted to mention it here first in case you wanted me to troubleshoot.

Had to roll back the server. I’ll hold off on updating it again for now.