Possible issue with 'startAudioOnly'?

@damencho

When I set startAudioOnly:true in my config.js and join a meeting, jicofo reports participants this way:

<videomuted xmlns="http://jitsi.org/jitmeet/video>false</videomuted> - Indicating that video is on.

This clears up if quickly start / stop video from the client. I can also use some combination of startAudioOnly:false with startWithVideoMuted or startVideoMuted but these both ask for camera permission and quickly turn on and off the camera when users join, which is not really ideal.

Can you think of some other combination to get to report properly without enabling video? Any ideas?

Edit: Maybe this is why?

It looks like alternadom already opened an issue for this on github:

Probably low on the priority list. Let me know if there is some trickery I can do on the client side without asking for video. I’ll keep looking either way.


(Edit)
➤ I found a work-around for others that may find their way here.

You can look for <videoType> in addition to <videomuted> - If there is no <videoType> then it looks like you can safely assume that video as not yet started even if you find that <videomuted...>true</videomuted>. After video as been enabled at least once, <videomuted> is correct.